Find and Find Next?

I’m in Xojo, sitting in the Code Editor, viewing a particular method. I would like to do a simple Find, Find Next, Find Next (etc) on a certain word or term, but not sure how. If I do a command-F or hit the FIND button, the Search and Replace pops up and I can find all the occurrences of what I want, but I cannot easily move from one to another. I hope I’m missing something obvious. For instance, let’s say I wanted to find and one by one move to every finding of “ASDF” in my method, I might want to jump from one “ASDF” to another. In the past, I’d FIND “ASDF” and then hit Command-G (or whatever) to find the next occurrence of it. I would move within the text itself from place to place. How do I do that in Xojo? THANKS!

I’d like to bump this… this is such a critical feature for me, I use it all the time.

I did find out that you can change the scope of the search, using the little action button just to the right of the search field, but there still isn’t a quick way to find the next instance with the keyboard. You have to click through each result. Personally, this disrupts my workflow tremendously (not to mention having to remember to change the scope back when I want to search the project).

If anyone knows of a solution, please let me know. I’d provide feedback but it keeps telling me the feedback system is not installed, and asks me if I want to install it, then it says the installer isn’t installed, and asks me to install that, and then nothing happens. A bit clunky, guys…

[quote=19049:@C Mana]I did find out that you can change the scope of the search, using the little action button just to the right of the search field, but there still isn’t a quick way to find the next instance with the keyboard. You have to click through each result. Personally, this disrupts my workflow tremendously (not to mention having to remember to change the scope back when I want to search the project).
[/quote]

I think what you are looking for is described in a bug report by Geoff himself, feedback://showreport?report_id=25076 - Find Again (Command-G) is not working. It was verified May 13th, 2013.

You can download the installer on the downloads page. I had problems like you did installing it, but downloading it manually worked fine for me. Click on the “Extras” link on the right of the download page.

It’s scheduled to be fixed for r3.

I just went from the 2016r3 and command-G worked, to the 2018r4 and it does not work anymore
Is there a solution ?