FileTypes RunTime Error - Xojo 2018r1

I need help working out a FileTypes error.

I have a fairly mature application that had always been released as Windows Only. Many users wanted a MacOS or Linux version. So, with the help of a couple friends we added a few #Target additions and had a MacOS version working pretty well. However, MacOS had a problem finding files and we had to do some modifications to the FileTypes listing.

We finally got everything working fine and built the current release using Xojo 2017r3. However, the same code raises a Runtime Error in Xojo 2018r1 while assembling the code for FileTypes.

I copied just the FileTypes to a new Project and get the same error so am sure it is something in the FileTypes definitions that is causing the error. I can easily send or submit the test project for anyone that wants to have a look and help me resolve the issue.

Thanks in advance,
Ron Bower
Ellicott City, MD

Please (as always in such cases), create a Feedback Request. :slight_smile:

Sascha - already did. Now the Feedback reporter gets an error when launched and it will not report its own error.

You could share the project on Dropbox or somewhere similar, and give us a link. Or you can email it to me at gavin (at) libertyapp (dot) com and I’ll take a quick look for you.

Gavin - You should be able to download it here:

It will be obvious that we were having problems getting file types defined for MacOS. Please be gentle…

The source build without issue with Xojo 2017r3 but not with Xojo 2018r1.

Ron Bower

Fixed it. There are hidden characters at the end of the descriptions for ADIF and RSD. 2017r3 must deal with these better than 2018r1 but anyway, if you remove them, you’ll be back up and running.