File not found bug

Hi. I created a very simple layout and when trying to run it, I get this error. What do I do? This is Xojo version 2019 Release 3.1. I am working on a Mac Studio, running macOS Monterey. This is the bug report:

Linking Executable
ld: file not found: /System/Library/PrivateFrameworks/UIFoundation.framework/Versions/A/UIFoundation for architecture x86_64

You may have to use a more recent Xojo (in tune with your hardware / sofware)…

I bumped into the same error with 2019R1 and 1.1, but 2019R3.1 worked fine. You may simply want to reinstall.

1 Like

What kind of project ?
iOS ? Web ? Desktop ?

Download Xojo 2019 Release 3.2
From the Release Notes:

Fixed linker error that occurred on macOS Big Sur.

Thanks, downloading the 3.2 version fixed it.

I’m glad that is working for you.
Can you change the “solution” to one that mentions 3.2?

Sorry, I wrote 2019R3.1. In fact, it was indeed 2019R3.2.

1 Like

I know you can’t edit your post. Maybe one forum admin will change it.

It looks like you need to ask an admin to edit your post if you wish to change 3.1 to 3.2 there.