Feedback / Bug reporting broken in 1.1?

Maybe it’s just my install, but I just loaded 2020 R1.1 on my MacBook Pro and when I selected the Feedback menu item from the Help menu, Xojo silently crashed. On restart, a dialog came up saying that Xojo encountered a problem on the last run and asked if I’d like to report it. When I clicked on the reporting button, it silently crashed again. This is reproducible (but obviously, not reportable). Am I the only one this is happening to?

I’ve been in and out of Feedback all day without issue. I’ve just tried the various methods of accessing Feedback (directly launching the Feedback app, launching it from the toolbar button in Xojo, and launching it from the “Feature Requests & Bug Reports” menu item under Help), and all work for me. You might try reinstalling the Feedback app.

If that doesn’t work, maybe delete Feedback’s folder in ApplicationSupport:
/Users/username/Library/Application Support/Xojo/Feedback

It will crash like that if you don’t have feedback (a separate download) installed.

(Edit: get it from Download-Extras on Xojo’s site)

I just tested and I confirm.
At first, I just removed all Feedback instances on my mounted volumes without quitting the IDE; the IDE told me “Feedback is not installed. Would you like to download it now?” and I chose “No”.
Then I quitted and relaunched the IDE and the Feedback button led to the crash of the IDE:
Crashed Thread: 0 Dispatch queue:

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

VM Regions Near 0:
__TEXT 000000010bf7a000-000000011be59000 [254.9M] r-x/rwx SM=COW /Applications/Xojo 2020 Release 1.1/

Thread 0 Crashed:: Dispatch queue:
0 0x00007fff3acdc9ce CFURLGetBaseURL + 6
1 0x00007fff3ace8816 CFURLCopyFileSystemPath + 68
2 com.xojo.xojo 0x00000001104f017d FeedbackSystem.Location%o% + 269
3 com.xojo.xojo 0x00000001104ee288 FeedbackSystem.IsInstalled%b% + 40
4 com.xojo.xojo 0x00000001104ee368 FeedbackSystem.Launch%b% + 40
5 com.xojo.xojo 0x00000001104ed0db FeedbackSystem.GuidedLaunch%b% + 235
6 com.xojo.xojo 0x000000010c2e389e IDEApp.HandleCommand%b%oo<Commands.Command> + 21566

Bug report 61726, I assume the same as what you’re seeing, is marked as Fixed.


Thanks all. Yes, it is identical to 61726 (now that I can get in to see it). Reinstall of Feedback app fixed it. Thanks all.

1 Like