Feedback app not installable

I just received the notice there’s a new version of Xojo Feedback. Automatic install failed, so I tried to open the DMG manually and got a “resource is occupied” (or whatever the English translation may be) on that. Could you install Feedback correctly?

Same here. I downloaded a working version from here


I got sucessful installation(Windows 8.1 64Bits) but just in english. For other languages as Spanish is not possible. I think that this release has a problem with the installation and must be reviewed.

I also got the resource busy message for the DMG file. I ended up option dragging the file to the desktop to make a copy and opened and installed from there. It does seem like something is wrong with the install routine. I also tried quitting Xojo to see if Xojo was making the DMG busy, but it didn’t help.

Yeah, something is wrong, but I can’t tell what exactly. The resource busy is caused by the fact that the DMG is actually mounted, but it seems it doesn’t get a proper mount point or something. So when you try to mount it again, you get the resource busy error. Disk Utility will allow you to unmount, mount correctly, and then install manually.

Could be an issue with the old version using a bad hdiutil command, or with the new dmg being built in a way the old version isn’t expecting. Can’t tell if either are true, it’s just a guess.

Are we all on Mavericks? Looking at the updater code from my repository - the same code Feedback uses - it looks like the response from hdiutil is expected to have EndOfLine.Macintosh line endings, when it is coming back with Unix line endings. So either Mavericks changed the output of hdiutil, or some version of Xojo changed how the shell returns line endings. Mavericks being the culprit is more likely.

The disk image is being mounted correctly, but it uses both the -noautoopen and -nobrowse switches, so you don’t see it in Finder. The problem is the updater code is trying to parse the output of hdiutil to determine what the mountpoint was.

There’s no solution for released versions. The old version, and almost certainly 2014r1 are expecting Macintosh line endings, and receiving Unix line endings. A ReplaceLineEndings call sure would have been a smart move here…

This is a perfect example of why my newer auto-update mechanisms download an updater. Rather than rely on the installed version to do the install, the new version does the install, so legacy problems like this can be fixed, rather than saying “sorry, v1 cannot update to v2.”

Just go get the latest version from our downloads page:

No. I got the “resource is busy” on Snow Leo.

Feedback no longer runs on Snow Leopard. It’s compiled with 2013r4.1.