Feedback 2017r1.1: adding comments

I’m unable to post public comments on existing cases with the new Feedback.app - all get marked as being private. Anyone else seeing this?
feedback://showreport?report_id=48383

which case are you trying to add comments to ?

As noted in the Feedback case, this seem to happen on all cases for me, even my own. Further samples are feedback://showreport?report_id=40743 feedback://showreport?report_id=18647 feedback://showreport?report_id=15130 which I commented today.

But new cases and requests to state changes are apparently not affected, see feedback://showreport?report_id=14298

Maybe I was to chatty :wink:

Every one of those has a new comment from you today

Each of those comments is private, I think that wasn’t the intention, and that’s the bug.

Yes, Tim is correct. When I submitted Feedback case 48421 the only option available was ‘Only me and Xojo’. I could not select my comment as a public comment.

Not sure if this has been reported yet, when I run the example 48421 feedback case a second time, it says that the Feedback program (2017) is not installed and asks me to reinstall the program before submitting the feedback case.

@Norman Palardy may know about it already and I did not want to make a duplicate feedback case as it may be marked private due to the previous issue Tim mentioned.

Exactly, this seems to happen to all of us.
I for example added a Feedback for Pre-Release Testers: feedback://showreport?report_id=48404, but forgot to add the example project.
Doing that only gives me the choice to “add info” for “Xojo and me”.
I already reported this a couple of days ago: feedback://showreport?report_id=48405, but that “needs review” :slight_smile:

thanks for the confirmation

then this is probably a duplicate of mine feedback://showreport?report_id=48383 which is awaiting review as well. But yours seem to be private at all. At least my new cases are still able to set to public.

Yup… sometimes I’m too cautious when mentioning any PreRelease-words :slight_smile:

I’ve marked mine as a duplicate of yours.

Right - just don’t forget to add the example project such as I did :wink: Otherwise you’re currently only able to add it for “you and Xojo”.
Which is a pity, as sometimes some other users actually try it, and even find a workaround one hasn’t thought of :slight_smile:

as far as I’m aware of, Feedback 2017r1.1 did not have public pre-releases at all. But it was available for download with the same version and a different build number before, so it seems to have received an silent HotFix or maybe HotBug :wink:

Yes there were two builds of Feedback 2017r1.1, but the only thing that changed between them was a problem with the Windows installer.

I’m curious though… you’ve said several times that you are “unable to post public comments on existing cases”. Can you elaborate? Are you getting an error? Is the PopupMenu disabled?

No error.
The PopupMenu is not disabled.
However:

  • click ‘add information’
  • the only choice in the “Visible To” PopupMenu is: “Only me and Xojo”
  • the “title bar on top” displays: “Visible only by (name or original poster) and Xojo”

Have you read my feedback report feedback://showreport?report_id=48383? The details are given there as it is always stated Feedback is the place to post bug reports, not the forum. I just wanted to raise some attention here.

Edit: Oh I see Jürg was just a bit quicker then me. I can confirm his observations.

Why is this still broken?

Because we haven’t had a chance to look at it in depth yet, and can’t replicate it in a cursory inspection.

To clarify (because that wasn’t supposed to sound as mean as it did) I was trying to elaborate on a bug report (#48443) and ran into the issue. I was legitimately curious to the status of this issue with Feedback.

@Greg O’Lone
I’m experiencing the same issue of the “Visible To” providing just “Only me and Xojo” with no other options. Today I commented on feedback://showreport?report_id=47143 and feedback://showreport?report_id=48383 but both were forced to be for “Only me and Xojo” when they should have been public to everyone. Feedback 2017r1.1 is running on macOS 10.12.5.

I am still experiencing this. @Tobias Bussmann says in the report that using older Feedback works just fine.
The feedback download in the Archive Downloads section is not feedback, it’s the Xojo installer…
Anyone have an archived copy of Feedback 2016 for Mac?

[quote=338480:@Tim Parnell]I am still experiencing this. @Tobias Bussmann says in the report that using older Feedback works just fine.
The feedback download in the Archive Downloads section is not feedback, it’s the Xojo installer…
Anyone have an archived copy of Feedback 2016 for Mac?[/quote]
Please don’t use older versions. We are working to get a new build to you next week.