'Failed to locate Framework DLL' in Centennial

From what i read from this UWP format is that it uses a virtualized (sandboxed) filesystem and registry, probably you can not simply look with a filebrowser or regedit.

Indeed there is some magic involved in the Desktop Converter work. Ultimately, it should be for Xojo to verify compatibility with that environment, as IMHO it is just as strategic to be able to place Xojo apps in the Windows Store as it is in the Mac App Store.

The DesktopAppConverter is already bundled in three installers ( InstallShield by Flexera, WiX by FireGiant, and Advanced Installer by Caphyon) , and chances are the new application model will become more and more popular, beyond the WS. Having to go back to 2015R4.1 and lose the HiDPI support in the process is no way to work.

Given the usual Apple bias at Xojo, though, we may have to evangelize, to convince the powers that be that it is necessary to address the issue. So far it seems absolutely nobody from Xojo has any interest in this topic.

If one of us can find more about what is stopping 2016 apps from converting, then it could be what is needed to catch Xojo’s engineers eye.

I just looked at the actual installation folder of a converted Xojo app in Windows 10. Everything is at the same place, no DLL has been removed. But the exe no longer runs by double click. The file has the same checksum, so I have no idea what prevents it from launching. Probably permissions.

Here is what I get :

I wonder if that could not be the issue with the Xojo executable, which itself may not have permission to access its DLLs.

I am hitting a wall with this for 3 hours:

[quote]‘E_STARTING_ISOLATED_ENV_FAILED’: Failed to start the isolated environment. See inner exception for more details.
At line:1 char:1

  • .\DesktopAppConverter.ps1 -ExpandedBaseImage C:\ProgramData\Microsoft …
  •   + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
      + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,DesktopAppConverter.ps1[/quote]

An earlier error when I used the Windows Store’s version of the converter was also ‘E_STARTING_ISOLATED_ENV_FAILED’ but with “At line:1char:” as “C:\Program Files\WindowsApps\…”

Also WriteErrorException.

The Write error may come from not starting PowerShell as administrator. Or some issue with the path where AppX is generated. Here, it is C:\Output. Maybe you want to verify that directory is open for writing ?

There are several threads on msdn about ‘E_STARTING_ISOLATED_ENV_FAILED’, such as https://social.msdn.microsoft.com/Forums/windowsapps/en-US/42d4e89e-23a8-43dd-8751-c4f910590c5f/cant-convert-win32app-to-uwp-project-centennial?forum=wpdevelop

Most of them seem related to the converter installation process. I experienced a slew of difficulties, until it became available in the Windows Store. Then I installed Windows 10 anniversary Edition, installed the DesktopAppConverter from the Windows Store, and problems were gone. Make sure the baseimage number is the same as your Windows build.

Have you looked at the logs ?

I followed the instructions and I did run PowerShell as administrator. The WriteErrorException were referencing to “C:\ProgramData\Microsoft …” and "“C:\Program Files\WindowsApps\…” just after PowerShell was showing something like “Starting Isolated Environment”. BaseImage is 14393 and match my Windows 10 build.

I have also ensure that my installer runs to the end and does not wait for the user to click a button or return from a prompt as I understand the converter runs the installer in the background during converting process and would hang starting isolated environment. I tried both an exe and msi installer file.

Maybe I try again with the latest Windows 10 Insider Preview. Hopefully they have a corresponding BaseImage.

To add:
I have also tried output folder at Documents and in C:\. Documents should not be a problem. But nothing.

Where is Appx to be found? In the output folder? Obviously I cannot find mine because the conversion did not finish.

You may want to ask for assistance in both https://social.msdn.microsoft.com/Forums/en-US/home?forum=wpdevelop and Stack Overflow. I found that the later often triggers more results from other Microsoft MVPs for some reason. Seems each is cantoned to his own forum on msdn.

Thanks but I will skip asking there. I do not intend to convert my desktop apps. I am just trying to see if I can identify where/how the “Failed to Locate Framework DLL” may come about. I will give another go on my Windows Insider machine and see how. If I still hit the wall or another wall there, I think I will just give up.

I prefer to go straight to UWP and target not just desktop and Surfaces, but also phones and others - write once, compile once and it runs on all UWP supported devices.

Fair enough. I do have native UWP apps, but in the case of relatively complex apps already existing, rewriting them would be a real bother to me. Especially since I do not know yet their potential in the WS.

Converted apps should execute perfectly fine on Surface 2 and other ARM Windows tablets. Surface Pro 3 and 4 will of course be happy with x86 like any standard PC.

Windows Phone has sold anecdotally, and represent such a low percentage, I rather make sure I have an app under Android. Plus even if code executes the same way on Windows Phones, the UI must be adapted to the small screen.

Converted desktop apps will not run on ARM devices. It will only run on Intel. That’s why I prefer not to convert.

Native UWP app UI will adapt to big, medium and small screens. Layout can be designed to auto flow or change whichever way you want. This is not a problem. Open the Windows 10 Money and Weather apps and change the app window size to mimic tablet and phone screen size and you will see what I mean. This is all very easily done with the XAML controls.

I am intimately familiar with Responsive Design. Thank you.

I have problem installing DesktopAppConverter and BaseImage-14946 in my Windows 10 Insider build 14946. Another WriteErrorException.

Sorry, I have to give up trying to help.

I have installed the DAC from the Windows Store. It is much easier.

But don’t worry. We will all get there. Thank you.

My application FileName Extreme was today successfully submitted into the WAS without error. It says it will take <16 hours, or up to 3 business days to process. My MS rep says it has been pre-approved. I hope it gets accepted. I used Xojo 2015 4.1.

The MS rep wants me to insert more apps into their store. I think they are desperate to catch up with Apple!

Yes, my MS Rep is pretty eager as well to see this through. Me too, I admit.

Businesswise, I am sure the WS needs our apps, but by the same token, I would not mind bringing up more business on the Windows side. Direct sales have been doing down, just as it happens on the Mac side.

[quote=294170:@David Cox]My application FileName Extreme was today successfully submitted into the WAS without error. It says it will take <16 hours, or up to 3 business days to process. My MS rep says it has been pre-approved. I hope it gets accepted. I used Xojo 2015 4.1.

The MS rep wants me to insert more apps into their store. I think they are desperate to catch up with Apple![/quote]

Well, you may be the very first one with a Xojo app in the WS.

Then you will have the honor to start the “Xojo apps in the Windows Store” which I wish will be as vibrant as “Xojo Apps in the Mac App Store”

I think I have found a workaround to convert 2016R3 apps :

  • Convert the silent installer
  • in the output folder PackageFiles, drag a copy of XojoGUIFramework32.dll next to the exe
  • Use MakeAppx to make a new AppX from that PackageFiles folder
  • Sign the AppX
  • Install and run.

That’s it :slight_smile:

Don’t do that in the builds folder. The DAC would see the two indentical DLLs and remove the Libs folder. This has be done after conversion.