Extreme slowdown of the codeeditor in the IDE

Is anyone else experiencing an extreme slowdown of the codeeditor in the IDE?
It must be related to autocomplete because in a comment line typing is very fast again.


Not on macOS. Have you tried the latest beta?

Anyway, it would be nice if we could simply disable this whole automatic background lookup and let it perform when typing tab or another key combination. And/or give the autocompletion a timeout of maybe 250 ms so that in any case we can type code as quick as possible.

Yes, same issue with the latest beta.

Yes, on Windows it is much slower.
macOS it’s up to speed though.

Feature Request: Disable Auto Completion, #70992

Cmd-Space is already taken by macOS to display the Search window (macOS Search Feature).

Yes, a different shortcut may be used… eventually

Apple also has a Control key. But triggering auto-complete could be done also by tab key.

Have-you tested Xojo 2022r3.2 ? (or the Beta)

Yes he did

My fault. I recall someone asked, but my stomach was crying loud and I do not hear the answer :star_struck:

I personally do not see any slowdowns in my main project (also Windows 11 and German).
Do you have big classes and/or long methods?

It certainly has something to do with the project, but only indirectly. The effect also occurs with Eddie’s Electronics. But not as strongly. So the bigger the project, the stronger the slowdown probably. For example, we have our framework in all our projects, which consists of many nested modules and classes. However, autocompletion does not work for nested modules/classes most of the time anyway.