Exporting / Importing FileTypeSet doesn't work

I made a large FileTypeSet on Windows, and exported it to a USB stick.

Put the USB stick into the Mac, and imported it into my project.

The FileTypeSet is there, but it is completely empty. Exported again and got the same result. Can anyone verify this?



True. The imported FileTypes is empty, even if imported into another Windows project.

Tried it quickly in several older IDE’s
None of them work either (I stopped checking when I hit 2012r2 and it also failed)

I understand FileTypes were completely rewritten for 2015r3 … any chance this is fixed? Otherwise I suppose I should file a Feedback report.

Put the filetype into a folder and export the folder. That will force the filetype inside to be in Xojo_binary_code instead of Xojo_filetypeset and it will preserve the content.

Norman : would it not be the solution to drop the Xojo_filetypeset format altogether ?

Oh, yes, that does work Michel.

I had just filed a case: <https://xojo.com/issue/41590>

Your solution should be added as the workaround.


Thank you, gentlemen.

They weren’t rewritten
Significantly enhanced
The editor itself was a rewrite