Execute 2016r3 ?

Hello out there,

I have installed Xojo 2016r3 (German version) on a Linux Mint 17.3 with LXDE desktop.

If I start Xojo, I get the message (translated) “File 2016r3 is executable. Execute / Execute in terminal / Cancel”.

What must I do to turn off this message? Permissions for file “Xojo” are set to -rwxr-xr-x.

Thanks a lot.


OK folks, as there was no reply here, I asked the guys from linuxmintusers.de - who replied immediatly and directed me to an URL of ubuntuusers. So, if anybody of you will encounter the same problem as I, have a look at https://wiki.ubuntuusers.de/.desktop-Dateien/ (German)

And yes, I am a little bit disappointed with the massive no-reaction here …

Linux is kind of an after-thought here. There are a few users here who are Linux experts; but in my opinion if one can’t solve the issue oneself (either with intimate knowledge or searching for answers online,) Linux is not for you.

Check to make sure your distro, hardware, and libraries meet all of the system requirements:


You did the right thing by sharing the solution you found. It will be precious for other people encountering the same issue.

As for the non-reactions, don’t forget this forum is a forum of users, who participate on a voluntary basis. If you had filed a bug report, I am sure Xojo would have looked into it.

However, in the forum, it appears you were the only one encountering what you described. Apart from sympathy, I doubt anybody could have assisted.

You don’t need to create another desktop file. Xojo has created one. You can find it in /usr/share/applications/ .

I am ever facing the same problem, what i did is, just change the file management preference setting, on behaviour tab, in executable text file, move the options from ask each time to option run executable text file when they are opened.

Open nemo or natilus, edit menu - preferences.


@Asis: Hum, no - there’s no xojo.desktop file on my system in /usr/share/applications.

How did you install Xojo? I unpacked the tgz file using gunzip and then extracted the
tar file with tar -xvf filename.


@Detlef. In the last 3-4 years, my main OS is Arch Linux (http://www.archlinux.org). Normally on Arch and Arch-based distro (Manjaro, ArchBang, etc), Xojo can be installed through AUR system (http://aur.archlinux.org/packages/xojo/) maintained by one of the user in this forum. Xojo package in AUR is based on tgz packaging system. So, basically we are using the same “installer”, but Arch’s package manager makes life easier when installing a package/software.

Xojo used to provide deb package for debian and debian-based distro (Ubuntu and its derivative: Mint, xubuntu, lubuntu, edubuntu, and so on). But, I don’t know when it had been dropped.

If you can’t launch xojo app by clicking *.xojo_project, you will need to define the mimetypes by yourself.

We stopped because a bug in lintian results in this bug report to us <https://xojo.com/issue/41414>
Lintian doesn’t tell us what is wrong; just that something is wrong and then users get that warning.
So until we can resolve that issue we do not provide the deb packages.