Error When Debugging iOS App - new Machine

Hi all,

Getting the following error when trying to simulate my iOS app on a new Mac Book Pro (Apple Silicon). I thought it was my certificates so I have them all re-done and re-imported. Things are showing up properly the code signing team in the IDE. But I am still getting this error.


Compilation of MediaSwitcherlOS failed.

Ide version?

That’s usually a crash on launch. Do you have strings defined for each of the capabilities that you are using?

Also, if you haven’t already, download the Xcode additional tools and run the CrashReporterPrefs and set them to Developer so you’ll get an actual crash notification/dialog whenever an app crashes. Simulator run crashes will show up that way.

Not sure. I am running basically the same code that runs fine on my old laptop.

I’ll download the Xcode additional tools and see what is going on.

OK. So I downloaded the additional tools and set the preferences like you suggested. The crash dialog has not changed. Same message.

I don’t think it’s my code. I think it is something else. I just tried running the Analog Clock example written by Xojo and I get the same crash.


In finder go to preferences de-select the option (top) about extention names.
This should been fixed in 3.1 could be your issue.

Yeah. No dice. Same error.

Just tried again with a brand new iOS project and all that project had was a “Hello World” label on the screen. Same exact crash. So there’s a certificate issue or something.

Have you tried using 2021 r 3.1 ?

No. Am I behind a version on the IDE? Maybe I am!

1 Like

Well, downloaded r3.1 and now things seem to work!