ERROR ITMS-90096: "Your binary is not optimized for iPhone 5

Error uploading IOS app

ERROR ITMS-90096: “Your binary is not optimized for iPhone 5 - New iPhone apps and app updates submitted must support the 4-inch display on iPhone 5 and must include a launch image referenced in the Info.plist under UILaunchImages with a UILaunchImageSize value set to {320, 568}. Launch images must be PNG files and located at the top-level of your bundle, or provided within each .lproj folder if you localize your launch images. Learn more about iPhone 5 support and app launch images by reviewing the ‘iOS Human Interface Guidelines’ at ‘’ and the ‘iOS App Programming Guide’ at ‘’.”

Anyone know what filename it needs the image in

Do you have all the launch images in your app, at the appropriate size and name, that are described here?

XOJO has an app for that… and I created an “enhanced” version that creates named images for both XOJO and XCODE

320x568 is Points, this is covered by the 640x1136 (pixel) image : DEFAULT-568@2x [iPhonePortrait2x for XOJO]
There are only a specific set of images iOS supports/requires

  add_image 640 , 960,true ,"iPhonePortrait2x","Default@2x"
  add_image 640 ,1136,true ,"iPhone5Portrait" ,"Default-568h@2x"
  add_image 750 ,1334,true ,"iPhone6Portrait","Default-667h@2x"
  add_image 1242,2208,true ,"iPhone6PlusPortrait","Default-Portrait-736h@3x"
  add_image 2208,1242,false,"iPhone6PlusLandscape","Default-Landscape-736@3x"
  add_image 768 ,1024,true ,"iPadPortrait","Default-Portrait"
  add_image 1536,2048,true ,"iPadPortrait2x","Default-Portrait@2x"
  add_image 1024,768 ,false,"iPadLandscape","Default-Landscape"
  add_image 2048,768 ,false,"iPadLandscape2x","Default-Landscape@2x"

So I submit that perhaps you are not adding them to you XOJO project properly?

That makes no sense… since iPhone5Portrait images is supposed to be 640 x 1136
Note all images are @2x (or in case of iPhone6+ @3x) the actual “pixel” size… this is in order to represent the “Point” size

and when you say “accepted”… by the XOJO compiler? or by Apple (I’m betting the compiler, because Apples turn-around is days not minutes)

[quote=179974:@dave duke]When I upload the app via Xcode upload it fails to upload as it’s missing that odd resolution, you can see the error Xcode gives above it wanted that missing resolution file. When I created it , Xcode let me upload the app for review of the App Store. The app is now going through the review process.

But you can’t upload an app without that file, I’m guessing that have added a new format to the list![/quote]

You mean the app passed Application Uploader. That is only the first step. Now your app is waiting for review. In a few days, a human reviewer will actually review it, that is when the review process will actually take place.

Here is the list of launch imagesI used to submit the app I have in the iTunes App Store :

iPadLandscape.png iPadLandscape2x.png iPadPortrait.png iPadPortrait2x.png iPhone5Landscape.png iPhone5Portrait.png iPhone6PlusLandscape.png iPhone6PlusPortrait.png iPhone6Portrait.png iPhonePortrait2x.png

iPhone5Portrait.png is 640x1136

Nobody wants you to fail. Just wait and see what happens with the reviewer.

Dave - what version of Xcode are you running?

6.2… not sure why that would have an effect on actual requirements…
iPhone5Portrait should be 640x1136 pixels… per Apples websites, Xojos utilities, as well as other 3rd party ones
Iphone5 is a retina device, therefore it must have @2x images

IF the compiler accepts a 320x568 (@1x) image, then I’d bet the deployed result is up-scaled and therefore not as “crisp” as it should/could be (same as running the XOJO IDE on a Retina device I’d bet)

Sorry - that was aimed at Dave Duke. My thought being that he’s running an older Xcode.

No worries :slight_smile:
But I thought XOJO iOS required 6.2 (or if on Yosemite then 6.3)

Dave S. - I’m running into the same error and I used your handy dandy utility. Got the same error Dave Duke. So now I’m going to create a file with those resolutions and see if it accepts it.

Could it be that the plist file has the wrong resolutions in it and that’s being generated by XOJO? I’m using XOJO 2015.2.1

Change the iPhone5portrait.png to a resolution of 320 X 568, added it to the project (removed the old one), build it and it still gives me the same error when I try to copy using Application Loader. What now?

Not sure why Xojo is sticking with that antiquated method… when creating a Launch XIB solves the problem and is tons smaller… but I will admit it if only for iOS8 and up… but that is 70% and rising


Thank you for the reply, but I’m not following you, can you explain for a newbie how to resolve this?

Dave is referring to something in Xcode, not Xojo. It doesn’t apply here.

Are you using the new Launch Images asset in Xojo or a folder named Launch Images?

I’m using a folder named Launch Images - just dragged it into the application.

The image it’s saying is missing is the iPhone5Portrait image, which should be 640x1136 (Apple is referring to it as 1x, half of each dimension). Can you double check that it is present and the proper dimension? Also make sure you don’t have anything else named Launch Images showing in the navigator besides that folder.

Travis - Dave

So the problem was that I watched Paul’s video where he dragged the launch images into the project, which is obviously not the right approach.

Removed the folder and added a launch images object to the project, then dragged in my launch images one-by-one and submitted to the app store without any problems.

Glad to hear you are on your way.