Error 104 when Debugging

While debugging a web app I get message “Compillation of ‘xxx’ failed.” on just about everyother run. After dismissing message the Run work ok.

How can I get rid of this?

I suspect that the previous instance hasn’t completely quit when you hit run the second time and it can’t be overwritten.

macOS Sierra 10.12, Xojo 2016 R3, Chrome 53.0.2785.116
Just started experimenting with creating a web app using R3 and I run into the same problem. I simply start a new web project, Run it once and it works, possibly twice and it works, third time and beyond I get the “Compilation of “xxx” failed.” I save the project, exit Xojo and relaunch it. I open the saved web project, can run it twice, then it fails again. I’m using the free trial version of Xojo.

Have the same problem. Since changing to sierra the same error occurs.
It makes no difference whether I use version R3 or R2.1.

My workaround is to delete the folder .debug manually

Is there already a “better” one? :slight_smile:

Where are you saving your project? If saving to the desktop, it may be that the files are locked when your desktop is uploaded to your cloud account?

This project was stored in a dropbox folder and until the sierra update it works fine.
After the update, when this error occurred i moved the project to the documents folder --> Always the same error.

There is indeed a problem with debug builds under Sierra.


But also, you should definitely never run from a dropbox folder. Just search dropbox in the forum, and you will see tons of horror stories.

Better copy to the local disk to work, then opy back to dropbox when you are finished.

FYI Joe looked into this and believes he has identified the bug in macOS that is keeping some files in use.
And since it is an OS component doing this it prevents some files from being deleted by the IDE.
Since they can’t be deleted the next compilation fails.

Until we can get a reply from Apple or find a different work around for the IDE to use you may avoid this problem by disabling “Automatically allow downloaded signed software to receive incoming connections” in the Security & Privacy preference pane.
This should prevent the OS component that causes the problem from behaving the way it does that causes the problem.

Thank you for this update.

No luck, however. I had to look around to finally locate the setting in firewall options and uncheck it, but unfortunately, it makes no difference.

The Web build remains and does not go away.

What would be wrong with using rm, as the script does ? Works like clockwork…

Using rm can have unintended side effects.
IF a process is writing to a file and holds it busy and you use rm on it the file will appear to be deleted from the file system.
But that is in fact NOT true and now you have a file that is growing in size but you have NO way to do anything to it.
And if that process continues to write to the file it will eventually fill your disk & your system will fail for reasons that are not obvious.

The best answer is for Apple to fix what appears to be a bug.
And we’ll still see if there IS a workaround we can safely employ

Did you try restarting after this?

Another thing to try temporarily is disabling the firewall to see what happens. I don’t recommend leaving it off, but it’d be worth knowing if it changes anything.

I know this thread is way old, but has this been resolved with newer versions of Xojo? (I’m on a 2017 build of the IDE – yeah I know I should upgrade!)