Empty file list after WebFileUploader completes

I have a question with WebFileUploader.

I tried running the sample project “WebFileUploader.xojo_binary_project”.

After the upload is finished,
WebFileUploader.UploadFinished() is called,
but the list of arguments Files() as WebUploadedfile is empty.

Is this a bug?

My environment is as follows.
Xojo 2022r2
Mac OS 10.15.7

What kind of files are you trying to upload?, the example is forcing to upload png or jpeg image files.

I’ve tested it using that environment and seems to be working fine with Safari, Chrome and Firefox.

I have tried jpg files.

After trying several times, I could somehow imagine the cause,
but it seems that uploading is not possible if the file name contains double-byte characters (Japanese in my case).

I am attaching the file for your reference.
Could you please try it?

Thank you.

ex. ) this file name is “セミの写真.jpg”

Maybe because it‘s a bug :wink:


Uhm, weird, I can still see the file in the debugger:

In my case the content of WebUploadedFile() does not exist.
That is, WebUploadedFile(-1).

Captura de Pantalla 2022-08-10 a las 10.45.40

The difference (maybe) could be my server is running on macOS 12.5, while the browser is on macOS 10.15.

Thank you.
I can’t try it right now, but I’ll see what happens when I update the OS.

1 Like