el captain update problem

Just sharing an incident after updating to el captain.

in years using a mac and after dozen of software upgrades, it’s the first time it has happened to me

I have installed the the update and used it two days ago without problems, but the following morning, at the restart, the computer simply didn’t start, showing the apple logo and an empty progress bar…
starting in verbose mode didn’t help, showing the mac simply hanging without errors at the start
trying and trying, at a certain point suddenly the my MacBook has started again!

searching the web shows similar problems by other users, it seems related to third party kernel extensions

what drives me crazy is that the first startup after the upgrade went fine, than I have dozens of failed startups, and then suddenly it has booted again…
now I’m letting the Macbook on all the time, since I jave jobs to do this days that I can’t delay, and I’m afraid to restart it.

Has anybody of you experienced or heard of a similar problem?
there’s something I should check now that my mac is up to avoid the problem?

Giulio

I noticed booting and shutting down can have issues with OSX10.11
When it does not want to boot, I keep the on/off button pressed for several seconds until it shutdown. Then restarting works fine.

It only happens 3 or 4 times I guess.

Before upgrading, I customarily clone the disk to a USB one so in case I need to revert, all I have to do is boot on it and getBackup it the other way.

If you have not done so, I would advise you do it with the present system, so you have a way to recover if the entire machine goes south.

That said, I did not see what you describe going from Yosemite 10.10.4 (or so) to El Capitan Beta on a mid 2011 21.5" iMac.

You could check in to System Profiler; the Software categorty at the lower left includes Extensions & Disabled Software; have a look at those to see if anything stands out.

Also Applications > Utilities > Console. The system logs there often hide a wealth of information. I usually start by filtering on the keyword ‘kernel’ in the top right filter box. By looking at the entries in the list and also the timestamps of each entry, it may give you some clues as to what is happening.

Talking about OS X weirdness:

For some weeks, the Finder never launch at boot time.

One day, it was The Day: I’ve made an intensive search in my hard disk and found a plist that have a meaningfull text (launch on boot or someting like that). I quit the Finder (AppleScript), run XCode, changed this to YES (from NO) and quit / shutdown, reboot.

Since then: everything is OK.

Now, I will install El Capitan in an external hard disk and wait for version .1 to install it in my internal boot SSD … (to try to avoid troubles).

[quote=218101:@Giulio Mastrosanti]Has anybody of you experienced or heard of a similar problem?
there’s something I should check now that my mac is up to avoid the problem?[/quote]
If your issue is related to Kernel extensions, it’s probably Apple’s new System Protection that suddenly stopped the extensions from loading. If that is the case, it’s still mysterious why it didn’t so on first restart. But maybe disabling it could be a solution until the kexts have been replaced by 10.11 compatible methods: http://www.stclairsoft.com/DefaultFolderX/el_capitan.html

OK thanks for your answers all,
fortunately I have a lot of backups, both with Time Machine and Carbon Copy Cloner.

yesterday, ate the end of my work, I have shutdown the MacBook withut thinking, but fortunately it did restart again :slight_smile:
( but with a very long startup, compared to the past )

Iill remind the Apple’s System Protection issue if I have more problems

 Giulio

Make sure you file a bug report with Apple also.

OK all,
just to let you know,
I have understood where my El Captain boot problem was :slight_smile:

as I said you, after a lot of headaches, my mac was booting again, but today with my terrible pain it wasn’t booting anymore!
and was booting neither from an external disk clone updated today…
but IT WAS booting from another external disk clone that I made sunday, just after solving the problem

so I have decided to compare the disks, especially about 3D part system extension, and I have discovered that the non booting Disk had some extensions that the booting CD didn’t have
I have removed that extensions from my internal hard disk too, and now it’s happily booting again.

In short:

  1. it seems that el Captain has BIG problems with some third part system extensions ( in my case was EyeTV extensions, if you don’t know EyeTV is a software to watch digital TV on the Mac )

  2. sunday, we have succesfully solved the problem moving the extensions in an ‘Unsupported’ folder, but in the middle of a lot of other operations following forum suggestions we where not aware that THAT had solved the problem when the mac was magically booting again

  3. since sunday I tryed to avoid to restart the Mac, but one time that I mistakenly restarted it, it booted just fine

  4. today I had the problem again, but it taked me a lot of time to realize that the difference was just that last night I have seen some television, and Eye TV reinstalled the extensions…

I was near to a point to erase and reinstall everything…

and the moral of the tale is:

keep a lot of disks around, and backup and clone as frequent as possible

 Giulio

Just installed on a spare machine: El Capitan doesnt recognise my wireless (non Apple) mouse.