El Capitan

My recently built application that is pending review for App Store and was working ok on Yosemite, now is not working on El Capitan.
Windows behave strange, not closing when they are supposed to, sheet windows appear as document ones, sometimes it can connect to the database but other times it fails to do so, and a long list of etcetera

Please file bug reports about these things. I haven’t seen those issues while running the IDE under El Capitan.

I have 9 Apps in the App Store, all build with Xojo 2015 R2.4. They are all behaving the same on El Capitan as on Yosemite.
My Apps use SQLite DB, HTTPSSockets, Sheet Windows and so on. Really, no issues here. 2 of my Apps even use Jeremie’s CustomUI and they look the same too.

Did you check if it works on another computer ?

Usual suspects:
Did you boot in the Recover partition and repair the HD / the permissions ?
Did you reset the PRAM ?
Did you reset the… (sorry, I forgot the name. It’s the mechanism that deals with USB I think) ?

I erased my El Capitan partition and restore Yosemite from my Time Machine backup and the App works fine again.

Now update to El Capitan again and run your App again. :slight_smile:
Do you see the same issues if you create a new Desktop App and just Build this without any changes?

In a set of client applications we had to add a number of label refreshes for them to get drawn properly. Otherwise, it was a fairly easy transition for one client.

I found one El Capitan (EC) gotcha this morning. We are using a USB to Serial converter in a project. The Xojo application wasn’t recognizing the serial port so I went on a quest to update the Prolific driver (anyone who’s worked with Prolific will know the horror in this). To my surprise I found EC-specific instructions and driver at http://www.prolific.com.tw/US/ShowProduct.aspx?p_id=229&pcid=41. You have to disable SIP before installing.

In my testing it appears that you can reenable SIP after installation of the driver.

So prolific’s drivers aren’t signed?! I have to install unsigned code into my kernel space to use them? Just more reason to only buy devices with an FTDI chip in them. Thats frustrating.

apart from that the only El Capitan problems I’ve had have been purely cosmetic. Apart from Mail refusing to move messages into other mailboxes… It’s working just fine for me. Though every so often it magnifies my cursor to about 10x the size for a fraction of a second. Not a problem, but shocking to see…

That’s a feature and can be turned off in the Accessibility system preference pane.

We encountered a bug in Core Image, that’s been on iOS for a few years, but only just appeared on OS X. Shows how the two OSes are merging. Apple very quickly fixed it for us too (and I’m presuming for iOS also).

I’ve not updated any ‘work’ machines just yet, will await the next point release.

we have a standing policy never to install the .0 release of any version of the OS. This is for all OSes, MacOS, Windows and Linux.


Until Yosemite; I would always update my main machine as soon as the GM was available. Now I’m more cautious.

I did a fresh install of El Capitan. Same strange behavior in my app. It is definitely related to the new OS version.

What is strange for you? Can you post some screenshots or videos?

There is a sheet window that opens when the user press an action button. Once he finish with that window and want to close it, the app verifies if he had save before closing and ask for confirmation. Once closed, the main window shows and the user keeps working on the app. It works fine on Yosemite. On El Capitan, this sheet window keeps open behind the main window but without any control on it (like an empty window) and the main window is useless

I cannot reconstruct your problem here. Sheet windows are behaving like intended. Did you consult the debugger to see if you didn’t create an instant instance and a new one unintentionally or something like that?

The only trouble I found so far in El Capitan is the missing prompt line in file open dialogues when you need to reallocate a file. I appreciate the smaller interface and really love the split screen which makes spaces much more useful on a 27" Retina iMac. But leaving the user completely in the dark is something that will hopefully be fixed soon.
Oh, and Default Folder is currently useless unless you want to mingle with the new system protection. But a compatible version is announced for October.

You know how to proceed: make a smaller example to reproduce your problem.

@Ulrich: ouch. A computer without Default Folder is like a cake without sugar. I will update my main computer only with Default Folder!

Yes, I miss it too although the native file selector remembering the last places has clearly improved. As I said, you can run the current Default Folder version, but I decided to wait for the update. I am glad the *1&?!! Creative Cloud finally seems to run reliably so I don’t want to change anything systemwise that maybe could endanger this situation.