EasyTCPSockets Sample Tests - Not Working

Hello ,

Did anyone tried the examples in EasyTCPSocket ? I tried to do a simple Client Server example using EasyTCPSocket Desktop example and apparently once I start on another pc the client to connect to that listening server they both simply just crash , both projects go to Pause mode and once I press play again I get An exception of class IllegalCastException was not handled. The application must shut down. On the server side as well on the Client side.

On the client side I have a simple Desktop app where I added a EasyTCPSocket , added the remote ip and port and a button where I have Socket.Connect

As well apparently while In the sample folder there are 2 examples as server , the only example as client is for IOS, desktop are same or they were just ignored or not added ?


Apparently I tested the IOS Client and I get exactly the same error, Server crashing while on IOS it Says Connected which is weird . I guess can someone from XOJO could review the examples and maybe fix it or post a fix for it , that would help.


Just Opened XOJO 2019 R3.2, same Example, run it. Opened IOS Client Test , works without any crash. So Apparently EasyTCPSocket is broken in the latest XOJO, or something changed that it does not work anymore

While doing various tests apparently the last version where EasyTCPSocket examples work is 2021 R2.1, R3 and R3.1 is broken so issue should be starting R3.

Some testing I did:

  • This only happens in the Server project (for me)
  • This only happens if App is a DesktopApplication and the port is already in use
  • This does not happen when App is changed to an Application
    • Set MenuBar to None to resolve the Type mismatch error
  • This does not happen if the port is available for the Server app to connect

I don’t have any resolution besides changing the super of App. I thought these details might help your case though.

Indeed, I just set MenuBar as none and changed the App to Application and it worked, I’ll update the case. Thanks Tim.