DynaPDF 32/64-bit problems with drawings


I’m working on a report using my DynaPDF starter license. I use a bunch of tables (everthing drawing fine) and at the end of the document, i want to paint a few frames onto it. But when i use a 64-bit project, i’m only able to draw some text (with g.Drawtext), filled ovals (with g.FillOval) or pictures (with g.DrawPicture) on my pdf. In 32-bit everything is displayed perfect!

The examples from MBS compile without any problems, showing everthing they should.

This is now my code for tests:

Var Mypdf As MyDynaPDFMBS = New MyDynaPDFMBS

Call Mypdf.CreateNewPDF
Call Mypdf.SetPageCoords(Mypdf.kpcTopDown)
Call Mypdf.Append
Call Mypdf.SetFont(“Helvetica”, Mypdf.kfsRegular, 9, False, Mypdf.kcpUnicode)

g = Mypdf.PageGraphics

System.DebugLog "Version = " + MyDynaPDFMBS.DynaPDFVersion

g.DrawingColor = &cFF800000 ’ orange
g.Pensize = 3
g.DrawText “Mein Text”, 50,150 ’ this is visible in my pdf
g.DrawRectangle 50,150,300,60 ’ not visible

g.FillRectangle 50,250,100,100 ’ not visible

g.DrawPicture logo, 50, 200 ’ visible
g.FillOval 50,200,100,100 ’ visible
g.FillRectangle 50,200,300,100 ’ not visible

Call Mypdf.EndPage

Var Mypdf_file As Folderitem

// No fatal error occurred?
If Mypdf.HaveOpenDoc Then
// We write the output file into the current directory.
// OK, now we can open the output file.
Mypdf_file = SpecialFolder.Desktop.Child(“My_test.pdf”)
If Not Mypdf.OpenOutputFile(Mypdf_file) Then
MsgBox “Failed to open output file!”
End If
Call Mypdf.CloseFile

HTMLViewer1.LoadPage Mypdf_file
End If

I can’t see what’s going wrong here…any ideas?

(Xojo 2020 1.2, DynaPDF, Windows 10 20H2)

Could you update plugins?
I think the FillRectangle calls were added in a newer version.

Here it looks like this:

and some of the drawing commands don’t show, as you draw something else over them. If you use different page areas for each call and different colors, you can see them all:

I tried to update the plugins to 20.5pr6 (renamed “Plugins” folder to “Plugins.204”, copied the newer “Plugins” folder to Xojo folder).

Now i can’t compile any of the DynaPDF demos…

App.Open, line 3
This item does not exist
MyDynaPDFMBS.setLicenseKeyGlobal key

…and 87 errors more.

Seems, that there is not a single plugin recognized. Most of the other MBS demos also fail to compile.

Does your license cover the new version you are trying to use?

I think so…valid until July 2021

Well, it’s 6 am in Germany, so Christian should be online in a few hours …

What does your plugins folder look like?
Just plugins files?

You have to honor the dependencies:

So if you install AVFoundation, please also install:

  • MBS Main Plugin
  • MBS MacBase Plugin
  • MBS MacCG Plugin
  • MBS MacCocoa Plugin
  • MBS MacControls Plugin
  • MBS MacCF Plugin

There is a feedback case 61849 about the compiler on Windows not reporting.

Ok…now i took the complete “Plugins” folder from 20.5pr6. Compiling works now, but the result is the same: in 64-bit no g.DrawRectangle, 32-bit works.

Feel free to send me a small test project to show the problem and I can try here.

No problem…where do I have to send it?


1 Like

Thanks. It works on macOS, but fails on Windows. I’ll look into it.

Problem fixed.

Please try newer plugin here: Dropbox


That’s true! :smiley:

Thank you, excellent service! :+1: :+1: :+1:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.