Dropobject not firing on Linux

I am trying to drag pictures on a window, but, while working as intended on Mac and Windows 10, it seems to me the event isn’t fired on Linux.

What am doing wrong?

Tried with 2017 r2.1 and 2017 r3, using Ubuntu 17.04.

In open event of the window:

The code in dropobject is never fired.

Please help


no problems here in Ubuntu 16.04

nobody can help you without knowing the code in dropobject,

you can make a simple test in dropobject

if obj.FolderItemAvailable then MsgBox("FolderItemAvailable") end if

Thanks for your reply Axel

Here it is the code in the dropobject; however I tried remote debugging the app with a breakpoint at the very beginning of the event:

dim f() as FolderItem

If obj.FolderItemAvailable and obj.FolderItem.Type <> “” Then
f.Append obj.FolderItem
Loop Until Not obj.NextItem
End If

if ubound(f) > -1 then start(f)

and never it fired.

But I will try the msg box method anyway.

Thanks for any help

Try being specific about the accepted mime type. Instead of an empty string, use “image/png” or “image/jpg”.

If I recall well I tried that way first but I’ll gladly try it again, perhaps using the msgbox method.


I am sure I tried before specificating my filetypes, now after trying with filetypes and msgbox it works

Thanks to both