DragReorderRows does not fire

mac os
I have set up a ListBox with multi columns, enabled “EnableDrag”, EnableDragReorder

I have a MsgBox as a test inside the DragReorderRows Event.
I can click and drag and i see the row shadow moving , when i release the mouse at a different row , the msgbox does not run …
the event is not firing ?

Please advise.

Do you have any code in the other drag events?

im only using DragReorderRows.
should i be using other drag events?

you must reply to dragenter if I remember all.

Actually not for dragging within the control.

[quote=328958:@David Cullins]im only using DragReorderRows.
should i be using other drag events?[/quote]
No, just making sure. Returning True in any of those events would prevent it.

Let me ask this question… when dragging, do you see the insertion caret between the rows?


I am returning false from the DragReorderRows Event.
I do not see any insertion caret nope …

Hello Jean

What do you by “reply” do you mean “return”

An horizontal line ?

[quote=329174:@David Cullins]Hello Jean

What do you by “reply” do you mean “return”[/quote]
Yeah, that’s what he means, except that returning a True in any of these events indicates that you want the drag to stop, and returning nothing is the same as returning False.

[quote=329173:@David Cullins]Greg,

I am returning false from the DragReorderRows Event.
I do not see any insertion caret nope …[/quote]
Ok. Please make a sample project for us so we can see what you’ve done.

it’ll take me a couple of days.,

so i did a test creating a new Listbox with a single column with only the DragReorderRows and it worked. The rows moved
and the caret showed up

my current project has the the list box “JobDetails” with 5 columns
upon CellLostFocus I am Setting jobDetails.Cell values
I tried remarking out the TypeEditableTextField code within “CellClick” which had no effect on moving rows and no caret.
when i click on a cell it goes into edit mode, if i click on cells 0-3 there is no shadow and no caret DragReorderRows … if i click
the very last cell where the cell is not editable i can see the DragReorderRows shadow but no caret. I cannot present all the code here as it is very large and will not post.

CellClick return false or before nothing
CellLostFocus returns nothing
ConstructContexualMenu returns true
ContextualMenuAction returns true
DragReorderRows returns false
Keydown returns nothing

In your sample project, make it 5 columns and make 0-3 editable. See if that reproduces your problem.

ok so i made 0-3 editable 4 and 5 static cells and still the same result. i can see the row shadow moving … no caret.

Hey Greg,

I forgot to tell you i am using this code to sort the same listBox
sorting is what is most likely inferring with moving the rows.

CusIdList.ColumnsortDirection(0)=ListBox.SortAscending CusIdList.SortedColumn=0 //first column is the sort column CusIdList.Sort

Greg sorry.
I thought i was sorting the ListBox in question, i am not sorting it.
the sort is for another Listbox. Sorry.

issue still exists.

Ok, now can I see your sample project?

greg how and where do i upload my sample text project.

Use the Feedback application to do these.