Drag and Drop not working

I tried to add the possibility to drop files to one of my Desktop-Apps, but it doesn’t work.
I have Windows 7 Professional 64bit and I tried with 2014r2.1 and 2014r3 and as it did not work, I just took the Example Desktop/ListboxDragAndDrop, which doesn’t work, too.
When I try it under OS X Yosemite, it works… but I need it to work under Windows.



I have tried and it is already in the Example. Under OS X it works, under Windows 7 it doesn’t.

In Windows, I have noticed it works better with FileTypes. Add a filetype, fill it with the proper mime types, or simply special/any, and use this in the Open event of the canvas you drop into :


The AcceptFileDrop method doesn’t work on my Windows7 64bit computer too, I have add filetype in filetype editor and add “me.AcceptFileDrop(TextFile.All)” in window’s Open event.

Is your filetype called “TextFile” ?

In the FileTypes1 area define the file as:

Display Name: TextFile Object Name: TextFile Extensions: .txt
The Extensions, if there are more than one, need to be comma separated and MUST have the leading dot. Then, in the code call


That should do it.

Only if you want to run on Windows (Linux ?).

On OS X, the leading dot is not mandatory AFAIK.

[quote=163293:@Emile Schwarz]Only if you want to run on Windows (Linux ?).

On OS X, the leading dot is not mandatory AFAIK.[/quote]
True but Marcus stated in the first posting that he was looking for a Windows solution.

I have a similar issue. The drag and drop from one listbox cell to another does no longer work in applications running on window 8.1 64bit. This worked fine up to window 7 32bit.

A bug report with sample code would be helpful.