Does 2018r1.1 not build Linux x86 64-bit apps on Windows

I have tried to build an app a few different ways and Xojo freezes (it appears to be anyways) on the Linux portion of the build if you chooses Linux 64 bit on Windows 10. If I switch Linux to 32 bit, it builds just fine. Am I missing something?

AFAIK you should be able to build on Windows 10 64Bit OS for Linux 64Bit OS.

Weird, it just locks up. I have a debugger open as well and I don’t see anything.

Extensive logging is recommended if the debugger can’t point you to an issue. If it’s already locking up while the IDE is building your App for debugging, i’d open a FR and attach the project for Xojo Inc. to test for themself.

If possible, test it with another Xojo Installation (on another Machine?).

Are you Remote Debugging?

I’m running DebugView on the machine I am writing the project on.

It would be helpful if you could tell us when it freezes and what optimization settings you are using (Default, Moderate or Aggressive).

Hi Greg,

It freezes as soon as the window pops up stating “Linking Linux”

I left optimizations at Default.

Is this a medium/big application?
This question is just because you’re saying that you’re using 2018r1.1. And building “large applications” (*) on Windows for Target Linux-64Bit only works successfully with 2018r4 and newer: <>
And have you tried the latest Xojo IDE’s - does it work with 2018r4 or 2019r1?
i I think to remember that someone has created a simple example with about 300 classes/project-items that would fail to compile before.[/i]

Actually it’s pretty small. At the moment, maybe 40 lines.

At least for Windows, There are too many UI bugs in apps compiled with 2018r1. Try 2017r3 or 2018r3+