Disable shadows for screenshots

When taking screenshots on macOS I really don’t want the shadows. There is a Terminal command:

defaults write com.apple.screencapture disable-shadow -bool true
killall SystemUIServer

However, in BS/M1 this does’t remove the shadows anymore. Does anyone have another idea? There is also the possibility to add the option key. But this uses too many of my fingers to remember.

Strange. I don’t get shadows when using CMD-SHIFT-4 in Big Sur. 'Course I have it go to the clipboard instead of a file.

I got plenty shadow:

If you don’t mind trying an app - have a look at Monosnap (in MAS). The free version has preferences to enable or disable shadows.

Using the Option key?
Such as here: ScreenShot without shadow
Ah… just read again that you know that. But does that work at least?

1 Like

I tried that. It’s really too many fingers.

Regarding Monosnap: holy guacamole. 100$ for a measly screenshot editor? Incredible. The free version is non-commercial use only. No, thanks.

Rebind it in System Preferences>Keyboard>Shortcuts>Screenshots?

I have to say the macs search is sweet how it takes you right to the setting, so nice for non-regular mac users :slight_smile:

Clever idea. But I can only change cmd-shift-4. Cmd-shift-option-4 is not changed and I don’t see how I can add a keyboard shortcut.

If you are using the capture tool, are you selecting an area, or using ‘Capture selected window’?

Rebind the one shown above to Shift F1 then Shift F1 followed by spacebar and it’ll go to clipboard with no shadow. Seems buggy though as it cuts off the border.

Have you tried Cmd-Shift-4 followed by the spacebar and then move the cursor to highlight the window and hit Return? That should get you just the window.

Am I the only one using the ‘Screenshot’ app? :slight_smile:

sorry no it gives you the window plus a shadow around the window.

With free TinkerTool you can disable the shadow from screenshots.

I use it, because it allows for cropping before capture, but I didn’t know that there was an option to disable shadows.

When I use it grab a specific screen, the grab I get doesnt include the shadows.
Presumably because they are part of the window area outside the window I chose…?

TinkerTool of course only reads the default value which is set correctly:

I’m giving up for now.

Presumably you did the Terminal command and forgot about it?

Yes, I like this app. I use the free one:

  • You don’t need to remember the Option + … commands, you just pick an icon
  • and you can edit the capture right form the app

I recommend.

I also like the Lightshot program. It works easier than Monosnap, but sometimes there are problems with uploading an image to the server.