Disable resizable doesn't work anymore.

When disabling ‘Resizable’ for a window, the window is still resizable.
You also need to disable Maximise Button to prevent the window to be resizable.

<https://xojo.com/issue/46286>

Only tested with macOS. May work correctly with Windows.

I hate to break it to you, it’s normal Cocoa behavior.
<https://xojo.com/issue/34275>

Well, If I am not mistaken it did ‘work’ with Xojo r3 :slight_smile:

Christoph, I am afraid you are mistaken. If you think about it, being able to maximize defeats the whole purpose of having a non resizable window. It has been working like this ever since Xojo existed, and probably before. At least in Cocoa.

Although in Christoph’s defense some of the ways how Window resizing used to work have changed as Apple have updated the OS. For instance a lot of my apps window have the “Full Screen Widget” on El Cap, even when that has been disabled, yet testing on Mavericks or Yosemite and they don’t.

Another way would be to set the maximum dimensions to the current window size.