Development Certificate Expiry

After my certificates expired I have been having problems trying to update my app for the store or testing. I know this is an impossible question to ask but it has been a few days on the merry-go-round now. So I need a fresh thought and hints on not making things worse.

The operation couldn’t be completed. 2021-06-22 05:37:46.590 xcodebuild[7386:353544] [MT] IDEDistribution: -[IDEDistributionLogging _createLoggingBundleAtPath:]: Created bundle at path ‘/var/folders/_k/fg8y_5yx097g4hyss0bn2vp40000gn/T/Surf Coach_2021-06-22_05-37-46.589.xcdistributionlogs’.

error: exportArchive: Provisioning profile “Surf Coach App Store Profile” doesn’t include signing certificate “Apple Distribution: Martin Fitzgibbons (79WGU83578)”.

Provisioning profile “Surf Coach App Store” doesn’t include the entitlement.

I notice I have 2 ‘3rd Party Mac Developer Installers’ in the keychain is that a problem or for different apps?

i feel your pain.
i have an app i cannot update because its impossible to work out which profile used which certificate.

new stuff? no trouble.

last years app?
dead in the water… code is good to go, completely impossible to deploy: <

I made some progress and have a build that I can install :slight_smile: I generated a new Apple Dev Cert with a new signing certificate, cleared out the old one from the keychain (which has probably broken something else) that fixed the first error. Then I removed Maps access and it built.
Now the problem is just getting Map access.
I added it to the certificate for the App and also in Xojo but no luck, it won’t build with it selected in Xojo??

I’m assuming you mean that you added Maps to the application Identifier for the App in the Apple Developer Portal, correct?

Correct, am I not suppose to do that?

Yes. Was just confirming. Now, in the IDE under iOS capabilities, you checked Maps. Did you check any of the options?

Yes, Photos and Camera

But next to maps, there’s an options button. If you click that, are any of the items checked? They shouldn’t be.

I just tried checking them all but get the same error

Uncheck them all. This dialog indicates which types of routes that your app provides to iOS. Not the other way around.

Tried it both ways but still gives the error.
Interestingly If I deselect maps in Xojo it not only compiles but works when I install it on my iPad.
I only use the following in the App

Just out of curiosity… what are you doing in your app that you think you need the Maps capability anyway?

The description on Apple’s site says this:

If this is it, you don’t need the Maps option for that.

Perhaps I should have asked how it is failing exactly…

If I had Maps selected (whether I was using it or not) It gave the build errors above.