DesktopLabel.defaults

I want DesktopLabels to always be created with Allow Tab Stop = False. Because of that i have created a DesktopLabel.defaults override. In this file there’s only:

AllowTabStops=False

But the IDE does not respect this setting?

I don’t know the answer to your question, but you should be able to achieve the same goal by adding a new subclass to your project, where you set AllowTabStops=False in the constructor. Then, just drag this subclass to your window.

Thank you. But this does not work automatically across new Projects. :slight_smile:

Ah, sorry; I didn’t know you needed it.

1 Like

It works if i write:

TabStop=False

I only found this out by looking at the source code.

How could I not know that…? :roll_eyes:

BTW: I’m trying to achieve something similar with a DesktopDateTimePicker.defaults File. Of course it doesn’t work there either…

Using:

Width = 92
GraphicalDisplay=True
DisplayMode=1
HourMode=2
TodayButtonCaption="Heute"

Only the Width Setting is respected… :unamused:

xojoinc/xojo#74348