Deployment to IIS

I’m trying to deploy a Xojo Web app to IIS. I’m trying to use CGI. I cannot believe how difficult it is and how little documentation there is around this.
I want to be able to install my application to various customers on their servers so I have to be able to deploy to Windows Servers running IIS.

I cannot get the application to work. Here’s the situation:

I’m trying to install to a Windows 7 64 bit, IIS7.5 setup

So far, I have:

  1. I made sure CGI was installed for IIS via the control panel.
  2. I created an Application pool (No managed code, Classic pipeline mode, Enabled 32-bit applications)
  3. I created an application folder via IIS using the application pool above
  4. I’ve installed Perl using these instructions:
    These instructions include setting up the Handler mappings for CGI and PL extensions as well as setting the CGI and ISAPI restrictions to allow Perl to work. A test Perl hello world app works!
  5. I have enabled the CGI Handler under handler mappings for the .exe extension
  6. I’ve copied all the build files and folders into the application folder
  7. I’ve set the permissions on all the files to Read, Write, Modify, Read and Execute
  8. I’ve turned off my virus checker that kept deleting the exe file when I tried to launch the application via the browser
  9. I’ve turned off my firewall in case that was interfering.
  10. I’ve got the config.cfg set to AUTO_PORT = 1 (I’ve tried various versions of AUTO_PORT and PORT settings to no avail)

I’m trying to launch the application (I’m now using the example application from the Web Deployment overview page) from a browser using localhost/TimelineViewer/xojotext.cgi

I’m now getting the “The application has gone off-line. Please try again later. This application has encountered an error and cannot continue. Some Fatal error”

Can someone please help me? Is there any documentation that I’m missing?

I have got to get this working but I have to say that the difficulty I’ve had trying to get this to work together with the convoluted setup of the server will probably mean I can’t use Xojo to develop web applications in the future.

Thanks in advance for any suggestions/help!

The recommended way to use Xojo web apps with IIS is to configure IIS as a reverse proxy to a Xojo standalone web app.

More information here:

try this:

  1. Go to “Handler Mappings”
  2. “Add Module Mapping”
  3. Use the following:
    Request path : *.cgi
    Module : IsapiModule
    Executable : /bin/PerlEx30.dll

Hi Lee,
Thanks for the suggestion.

My Perl folder doesn’t have this DLL. I installed the 64bit version of Perl. Maybe that’s the problem!

Do you know what the equivalent DLL is from the 64bit version? I’ve got:

This thread is very discouraging. Did you get it to work?

Since years my web deployment is stand-alone since IIS failed for every project on Windows. Hope this topic leads to better documentation on Xojo deployment on IIS.

Any progress yet Tim?

You HAVE to use ActivePerl and HAVE to use the 32 bit version
You CANNOT use the 64 bit version as it can’t start 32 bit apps (don’t ask me why but it can’t)
And be careful about running on a 64 bit server as it may refuse to start a 32 bit app (there may be a policy set up on the server about this but I’m not an IIS or Windows guy so ….)

Thats about all I know about this

i gave up on iis in the end and went with standalone, but i seem to remember that abyss server worked well and was much much easier than iis to get working

What is ISS standing for?
Is it possible to deploy Xojo made web apps to a personal server and not on Xojo cloud?

Radium Radiovich

Internet Information Services (IIS) IIS