deployment on OSX Leopard server

In order to avoid “Unable to launch application ‘test’ on port 39346” error, before to compiling the project, I’ve to change the “Application identifier” than it works !!!
I’m using Xojo 2013 R2.

That probably means that you have another web app running which is using the same application identifier OR a previous version of your app crashed and the mutex file is still there. Do you still have this problem after a restart?

Hi Greg,
I haven’t restart the Apache web, I have done these step :

  1. Changed App.identifier
  2. Compiled the project
  3. replaced project directory on server
  4. changed config.cfg to 666
    and it works.

Thanks

I don’t think a recompile is necessary. You have a few options if you are running your own server/virtual server:

  1. Stop the web server (Apache)
  2. Kill the processes with your app name (ps -ef | grep ) then "sudo kill -9 "
  3. Upload your files
  4. Set owner to _www for your config file (sudo chown _www ). You can also set permissions to something like what was already mentioned above. I prefer to set files that needs www access to the _www user.
  5. Restart your web server
  6. Visit the web app to “launch” it.

Note that steps 1 and 5 are optional. You can simply kill off the process if no one is using your web app at the time.