Deploying an application requires a Xojo Cloud Server.

I am not sure if this is related to my problem, but I upgraded to v4 today. I am working on a little app I created after my upgrade, and now I get the following when I try to deploy:

Deploying an application requires a Xojo Cloud Server.
If you have one connected to your Xojo ID and still cannot deploy, contact Customer Service.

I am connected to my Xojo ID. I am still able to deploy older, “established” apps. I have tried restarting my server and Xojo to no avail.

I just sent off an email to Xojo Customer Support and I received an automated response informing me that the Xojo Office will be closed from Monday, December 21st through Monday, January 4th. 16 days is a little longer than I can wait.


Have you unticked Xojo Cloud in the Build Settings? It is on by default for new web projects.

I am not sure what you mean. If i unstick Xojo Cloud in the build settings, Deploy becomes greyed out, and I cannot click on it.

Click on the Xojo Cloud target and see if a server is selected there.

Greg. I missed that. That solved the problem. Thanks and Merry Christmas!