Delay at Run (2017r3)

Since 2017r3 there is a new behaviour when pressing “Run” button (Green triangle).

If you have modified the code, Xojo takes some seconds (in my case more than 15) to start compiling.
But if you save just before pressing “Run”, then compilation starts immediately.
I can imagine that Xojo saves the code before starting compilation.

The weird thing is that saving takes just 2 or 3 seconds.
So, why does it take so long to start compilation if I don’t save before?
Probably because it must be saved it in a different file, but is this delay normal?
Have you noticed it as well?

(checked on Windows 10)

@Ramon SASTRE - this is by design.
See this discussion

[code]For advanced users who understand the consequences of turning this off
2017r3 now has an advanced preference available to turn off autosave.
This is intentionally not exposed in the IDE in 2017r3.

Confirm that Xojo is closed.
You can set ‘Autosave Allowed’ to false the following ways:

On macOS edit the Xojo Preferences ( ~/Library/Preferences/com.xojo.xojo)
Add a key with either a true or false value
Autosave Allowed

On Linux the same key entry style as macOS inserted in ~/.Xojo.Xojo

On Windows use regedit to edit HKEY_CURRENT_USER\Software\Xojo\Xojo
Add a new DWORD value with the name “Autosave Allowed”
a value of 0 is false
a value of 1 is true
[/code]

Thanks Joost,
I was away during November and I could not follow this discussion. I will read it now.
Probably I will find the reason of this difference between saving it manually or done by Xojo.