Debugging with security for ARM

How do I debug with ARM so that the security is set correctly? Isn’t the IDE supposed to have a local certificate?

Everything works fine in Intel mode. But for ARM I can’t access the keychain:

And the wonderful wonderful Automation security just says “no”:

Doing the codesign in debug mode totally freaks out Valentina and just makes crashes. How do I get the security correctly in debug mode for ARM?

You could build a sign script do sign with entitlement file and run that in a build script step.

I tried that but then Valentina crashes hard.

I ran the Keychain example under ARM and it worked fine. So it must be again something in my project… I’m so ecstatic.image

Urgh… got it. I have to add the Valentina files AND do the codesign and then everything works fine. So there is something with Valentina that ARM doesn’t like. Adding Valentina files and doing the codesign takes ages.

Finally took some time to find the root cause:

feedback://showreport?report_id=64615

64615 - After setting custom url the ARM debug build isn’t adhoc codesigned anymore

Steps: The attached example is the keychain project from the examples. The only change I did was to add an IDE script for custom urls directly from the blog.

For Intel everything works fine. For ARM it’s not possible to access the keychain anymore. If you remove the IDE script then ARM works fine again.

Expected Result:
Keychain example should work with IDE script for ARM

Workarounds:
Only do IDE script for release.

2 Likes
Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.