Debugger breaks at every single for-next loop

Realbasic 2011 suddenly started doing this… it’s never done this before. I cannot debug any application because every time I try to RUN, the debugger stops at every single for-next loop as if I had placed a breakpoint on that line.

I confirmed that it’s Realbasic, and not my app, by creating a new app with nothing but this code:

Dim Q, S as Integer

For S = 0 to 50
Q = Q + 1

and the debugger stopped at the “For S = 0 to 50” line. Each time I press Step (or Step Out) it proceeds to the next value of S.

What on earth could be causing this? Do I need to uninstall and reinstall? Is there some hidden setting I’m not aware of that I can turn off to prevent this? I am utterly baffled.

Oh, and it doesn’t do this when I build. Only when I debug.

Have you tried emptying the cache? And a restart? Sometimes Realstudio can get itself into a state …

I’ve restarted the program a bunch of times. I also ran Realbasic 2008 (which I have installed concurrently on my 'puter) and have discovered that it is doing the same thing!

Has anyone ever heard of this behavior?

[I’m going to try uninstalling (both versions… I haven’t used 2008 in a while) and reinstalling, as well as rebooting, and maybe it will stop doing this weird thing. I can’t do a blessed thing otherwise.]

Well, rebooting and reinstalling removed the behavior… I wonder what the heck it was.

Was this in Windows? If so, I’ve had this problem for many years going way, way, way back on many computers. I call it the Phantom Breakpoint problem.

You can fix the problem by rebooting, but it always can come back, usually after working for awhile. Restarting the program or clearing the cache does nothing, you have to reboot (assuming your problem is the same as mine).

I’ve told REAL many, many, many times about this and even sent an example project, but nothing has been done, likely because they they can’t replicate it. I do wonder why REAL/Xojo doesn’t have a diagnosis mode. It doesn’t (for me) occur in Mac, ever. On Windows it’s less likely to occur on a more powerful machine but it still occurs. That work in REAL/Xojo on Windows as little as possible, mostly because of this.

Told ya :wink:

Restarting the app is not enough. You really need to restart and clear out the cache and temp folder.

I still use RS 2012r2.1 mostly, and while I have never seen this before, I have noticed that RS is much more stable on a 64-bit Windows 7 machine, than a 32-bit machine I had access to up until recently. Just crashes less, and less weird, unexplained problems like this.

Xojo is getting better and better and at some point I am going to make the move, but it still doesn’t build my app the same as RS studio produces slightly slower code, that is noticeable in graphic areas on screens with a lot going on. And I have some issue with the Einhugur grid that gets drawn much sooner than the rest of the controls (on RS2012, it all updates at exactly the same time on Windows and the Mac). But it is getting there…