Debug Build silently(?) failing on Copy Files Build Step

A project that has been working well for several years is now failing to complete building the Debug (“Run”) version of the app. The weird thing is, it just kinda dies. There’s no error message or other indication of failure other than the failure to actually launch the app. I’m not sure where else to look for clues. I was initially tempted to blame it on the recent Xojo 2017 r1.1, but I uninstalled and went back to 2017r1 and it still fails there. So it’s definitely something with the specifics of my project.

I’ve narrowed it down to a single Copy Files Build Step: one that copies a large number of files. I have 5 Copy Files steps total for this build; if I skip that step, the debug build completes and the app launches. Unfortunately this Copy Files step is essential so skipping the step is not a realistic long-term solution.

This problem only happens in the Windows build; OS X is fine and has a similar (though not identical) Copy Files step (also with a large number of files).

One other thing that’s a little odd: a normal build (not Debug/Run) appears to work, but I found if I try to launch the freshly-built app immediately after building completes, I get errors that seem to indicate it’s missing some of the files in this large Copy Files step. If I wait 30 seconds or so, I can launch the app just fine. It’s almost like there’s a lag between Windows(?) notifying Xojo that the file copy is complete versus the actual completion.

Is there some sort of timeout or other limit on Copy Files (or any other) Build Steps? Any suggestions to try for working around this problem?

You wouldn’t happen to be building to DropBox or a network drive, would you?

No, neither DropBox nor network drive. All local. The machine is a VM, though. Windows 8.1, patched with all latest updates (I’m mildly suspicious it’s related to one of the recent security-related patches, but that’s just me).

Have you tried using Run Paused? I’d be curious to know if you launch it manually if it will actually launch.

I assume you cant revert the VM to another previous snapshot?
SSD or HDD?
Any anti-virus installed?
Any changes in software/hardware since it was working last?
Checked your system event log for problems?
Have you check disk’d the VM and/or the host OS?
If SSD, have you checked SMART?

It’s also possible that one of the files is now missing or that it has a character that’s illegal on Windows.

BTW, how many is “a large number of files”?

@JulianS : right, unfortunately reverting to an older (unpatched) version of the VM is not possible (security policy). I do note that a previous version of my project compiles and runs fine under the current environment, although the number and size of files in the Copy Files step that is currently failing has increased a little since then. The host machine’s SDD S.M.A.R.T. status is “Verified”. A/V is WIndows Defender (up-to-date and no problems reported). CHKDSK ran to completion with no reported problems/no action required. No changes to hardware; only recent changes to OS are Windows Updates (it’s currently up-to-date with everything relevant to Windows 8.1)

There is one potentially interesting event in Event Viewer that coincides roughly with the time frame of me attempting to run (this morning):

- System 
  - Provider 
   [ Name]  Microsoft-Windows-DistributedCOM 
   [ Guid]  {SOME_GUID} 
   [ EventSourceName]  DCOM  
  - EventID 10010 
   [ Qualifiers]  0  
   Version 0  
   Level 2  
   Task 0  
   Opcode 0  
   Keywords 0x8080000000000000  
  - TimeCreated 
   [ SystemTime]  2017-05-26T15:09:17.683762300Z  
   EventRecordID 30044  
   Correlation  
  - Execution 
   [ ProcessID]  636 
   [ ThreadID]  4884 
   Channel System 
   Computer WIN-XXXXXXXX 
  - Security 
   [ UserID]  S-1-[userID info] 
- EventData 
  param1 {SOME_GUID} 

However, this event is not repeated for every attempted launch (Run/Run Paused) so I’m not really sure it’s relevant to this problem.

@Greg O’Lone : Run Paused gives the same behavior as Run…the build/launch process just silently dies. No error or warning; app doesn’t launch (seems to get partially built, but doesn’t bring the build folder frontmost and give me the opportunity to launch). As before, if I skip the large Copy File step, the build succeeds and I can launch the app (which, of course, fails, because of the missing files from the skipped Copy Files step).

Re: “a large number of files”: it’s just under 5,000 files in ~200 folders for a total of about 70MB. This set of files operates fine under Windows independently (i.e. when not part of my project), and I can copy/move it using normal file copy operations, so I’m skeptical that anything is missing or using an illegal character, but I will try to verify that.

That is a lot of files. What if you were to instead try an IDE Script that calls a CMD batch file that actually copies the files? Or maybe split the Copy File step into multiple steps to see if that isolates the issue.

Have you tried to use a zip instead of individual files?

Could you also perform the test again and see if the event is triggered?

Can you post the GUID’s?

Could you time this and confirm it (roughly) happens the same duration every time?

This could be an indication of a permissions problem, possibly a corrupt permission or security descriptor.

It could also be that the CopyFilesStep is just timing out. That’s a lot of files.

Thanks all for the replies. After some trial-and-error, I was able to get it working by using @Paul Lefebvre 's suggestion of splitting up the single, large Copy Files step into smaller chunks. So there must be some kind of undocumented timeout or other limit (file count? Size of files being copied?) that snarls Copy Files with a large number/large size of files being copied.

That would suggest that it is a timeout on the copy being done

I’m surprised I’ve not seen that when running the IDE on Windows as we use a copy file step to run the debug version and I’m not seeing it timeout here and there’s a large number of files there too