Cross platform issue with weblistbox - records not showing on Linux

Background
This is about a Xojo Web App, not a desktop app. In case the weblistbox wasn’t a big enough clue :smiley:

This problem MAY be related to this one, although if it is, the workaround does not work. (The linked problem is a confirmed bug.)

I suspect these problems are unrelated

The problem
I am using a weblistbox in a container control in a pagepanel. The linked bug explains the problem and the workaround. I develop on Windows, and the workaround has worked flawlessly. While working on a completely unrelated issue last night or this morning (no sleep = lets do the time warp again), I came across an additional WebListBox problem.

  • In the debugger, everything works fine, listbox works as expected.
  • The compiled windows binary (32 & 64 bit) works fine, listbox works as expected.
  • The compiled Linux (x64) binary runs without a problem, BUT the listbox doesn’t show any records.

What I’ve tried

  1. First off, I added logging to make sure that I was getting data from the database. I am. The SQL select statement is returning the exact same records on both platforms.
  2. Next I tried removing the listbox from the pagepanel. No effect, the userlist is still blank.
  3. Next I tried adding data from a for next loop - no records showed, listbox is empty.
  4. I then created a brand new project and tried to emulate the problem. The buggy behaviour was present, but the workaround fixed it. The disparity between windows and linux was gone - the listbox worked on both platforms.
  5. Finally, I tried various hacks and code changes, no joy - listbox works on Windows, not on linux.

What I need

  • Anyone experienced anything similar?
  • Suggestions on where I can start troubleshooting.
    • How do you troubleshoot a cross-platform problem?
  • Any other help or suggestions.
  • A magic wand to make Web problems dissappear.

Thanks,

Jason

I have found the problem - everything on Linux works fine when the app is run as root. Running as a non-privileged user (currently www-data and custom user) results in the weblistbox not displaying records.

I’m marking this as the answer for now, but will update that if my testing reveals anything else. Here is the feedback link.

The feedback link has code that illustrates the problem.