Copy & Paste Stopped Working on Project


This just happened:

video clip

It seems to be project specific. I’ve quit, restarted, did a save as, etc… Any ideas anyone?


Shutdown and power on ?

Re-download and re-install Xojo ?

Check the project on another machine ?

Test the boot hard disk (and do not connect anything like SD Card, Memory Stick, Hard disk, CD / DVD / BR…

Thanks for the feedback Emile - It looks like the project became corrupt. I went back to a previous version and it opens fine. The project crashes opening on a different machine…

Thanks again

If possible (license), did you try to save it as xml ?

Yup, thanks, XML, Project and Binary

It happened again :frowning:

It looks like, either the project is already corrupt, but not showing symptoms or the steps I am doing is causing the corruption…

I am doing a few different things, but a lot of it is adding images

Use Arbed to look at it (to see corruption) and convert it to XML (just saved someone’s bacon on the mailing list)

Thanks Markus - I got a load of errors when the project opened in Arbed (so much that the OK button for the dialog was off the screen. Then I got a crash report from the App when I tried to save it… Doesn’t look good :frowning: Thanks for the help

[quote=260259:@Chris O’Brien]
…but a lot of it is adding images[/quote]

I have exactly the same here.
I went back to a backup and after quite some trial and error, I found out that it happens right after I drag in a new image resource. It doesn’t happen when i switch OFF Retina/HiDPI support.
So for now, I’m developing with this option turned off. And before a Build, I switch it on.

Great you found a workaround Marco… it’s happening to me on iOS, so I don’t have the option :frowning:

Looks like it might be a 16r1 issue - I was able to open the project fine in older versions of Xojo.

What format are the images? I’ve seen a couple of posts indicating there are problems with bitmaps and changing to another format will fix the issue.

In my case, the images are standard .png 64x64’s glyphs that I use for buttons. I tried changing the 72 pixels per inch to 144 but the problem was still there.

I cannot recreate the issue with a new project though. I’m currently trying to strip it down so I can submit it in a bug report.

All png. But the sizes can vary.

Does any know the dangers of saving in the old project format?

To get me around the problem for now, my hope would be to open the project in 2015r2.4, add the images I require and SAVE. Then go back to 2016r1


Last time I had troubles with a large project, I exported all items from the Navigation part, thenpower off, load Xojo, create a brand new one and import all items from the Folder I saved them at first.

With a bit more work, I get a fully worked project (as fully as was the last version of the project before the troubles).

Nota: beware on how you deal with App and the MenuBar (forgot the name). You’d better use Copy / Paste of what’s in App and re-create your MenuBar /Menus / MenuItems.

That is what I call “brute force re-creation”… ;-:slight_smile:

That sounds like a pretty good plan! Thanks for the idea and the time Emile :slight_smile:

This is a bug I already reported but I got a reply it is a very old known bug.
To bypass this, first select another control and then go back, the COPY will all of the sudden be available.

Marco’s project revealed a different bug which has been fixed for a future version

Thank you Norman

I think it was the same. When I added images to a project and HiDPI was enabled , it messed up the project and I needed to use the trick by first clicking on another control and back to het COPY/PASTE working again.

But HiDPI isn’t an option in iOS, is it?