<Control>.TextFont = "System" on Yosemite

Using Xojo 2014r2.1, when setting a control’s TextFont property to “System”, it appears to still be using Lucida Grande on Mac OS X 10.10 Yosemite and not Helvetica Neue. Basically, I’d like the control to use the proper font on Mavericks or on Yosemite, but I don’t want to have to hard-code Helvetica Neue.

This is happening on any control with a TextFont property.

Is anyone else seeing this behavior?

File a bug report.

System should quite literally mean “the correct OS X system font”

If thats not happening then there’s a bug

It has been submitted via Feedback. Case#36000 - ‘TextFont = “System” does not return Helvetica Neue under Yosemite’

I sure don’t see them visually being “the same”
In both my little tests (which are about the same as yours) System matches Helvetica Neue not Lucida


Norman,

I recreated your test here using Xojo 2014r2.1 on Yosemite. These are the results I’m seeing:

Although the differences are there when TextSize is 0, they are really noticeable with a TextSize of 24. Setting TextFont to “System” is definitely still using Lucida Grande.

Sample Project

I can say we do not hard code the font in any way shape or form - I’ve searched the framework code and there is no “Lucida” anywhere.
We always ask the OS for it.
You haven’t tweaked the OS settings in any way have you ?

No sir. The only thing I did was select “Reduce Transparency” from the “Accessibility” preference pane. But, turning that back off makes no difference.

Can you post a screenshot of my sample project?

Not at the moment as I’m on Mavericks and I’m in the middle of some other stuff that I can’t just drop and do this asap

No worries. Just curious to see if my same project ends up with different results on your system.

Hi Scott, I tried your test and get Helvetica Neue for System. I do find a slight spacing difference though between the two in a label (the 4th line has them overlaid). In a checkbox System 0 matches the OS.

That is so strange. What version of Xojo was your test done with?

I have done nothing with this system other than install Yosemite. As my screenshot above shows, it’s using Lucida Grande when I set TextFont to “System”. This is for any RectControl that shows text.

Everything else on my system uses Helvetica Neue as it should.

I have no idea what’s going on here.

As for the spacing differences, I read somewhere that Apple uses a slightly modified version of Helvetica Neue for the system font. I always assumed that meant the Helvetica Neue font included with the OS that’s available in the font list. But, I wonder if Apple included a different version that’s only accessible to the OS?

I should probably also point out that Greg O’Lone marked the Feedback case as “Verified” shortly after I posted it. I assume “Verified” means he was able to recreate the problem?

13r4.1, but I tried 14r2.1 just now with the same results.

I have no idea what’s going on. Any known Xojo-made application is showing Lucida Grande as the default font on Yosemite. A brand new project is doing the same thing.

Unfortunately, the workaround of hard-coding “Helvetica Neue” is not viable either because I can’t get the text to center vertically correctly on various controls, especially pushbuttons, unless I use a text size that is larger than standard.

My frustration-level is definitely rising. I have a project I need to submit an update for, but I can’t get this simple thing working correctly.

sigh The life of a developer…

So, I’m still seeing this problem, but the plot thickens. I just purchased a brand new iMac (21.5"—late September 2013) and wiped the hard drive and installed a fresh install of Yosemite, then updated to 10.10.1. Without doing anything else with the system, I ran a few Xojo-built applications, including the IDE (Xojo 2014r2.1). All are using Lucida Grande as the system font in windows titlebars and various controls (note the menu bar is using the correct Helvetica Neue). This is a completely different computer from the original computer I was testing on (a late 2013 15" Retina MacBook Pro). No users or settings were migrated. It was a clean install. All other applications (presumably not Xojo-built) are using Helvetica Neue as the system font.

The MacBook also continues to show this same behavior with Xojo-built applications. However, I had recently, for non-development-related reasons, created a new, additional user on the MacBook. Today, on a whim, I tried out one of my Xojo-built applications while logged in as that user. Behold! It used Helvetica Neue as the system font! I logged out of that user and launched the exact same application under main user on that computer and Lucida Grande was back as the system font. So, the issue is definitely something to do with the user. But, what totally confuses me is that the new iMac with a clean install—no migration, remember—also shows the same problem. And, again, it’s only Xojo-built applications.

I really wish I could figure out what was going on here.

Verified means that using your project, we were able to reproduce your results. That does not mean that it’s a framework bug.

OSX 10.10…2 - Xojo 2014R3.2

Permissions on the fonts folder or fonts themselves? If you replicate group memberships from User1 to User2 does the problem re-appear?