Control Set paint event does not fire

Using 2019r3 under Linux Mint (Mint running in a VirtualBox VM under Mojave).

I’m using the technique described here:

http://documentation.xojo.com/topics/user_interface/desktop/desktop_controls/control_sets.html (section on Dynamic Controls / Adding Controls at Run-Time)

to have a set of buttons that I add to or remove from, as the user does various actions. These buttons, when created or clicked, are then styled using the Paint Event of the superclass of the buttons. This superclass is itself a subclass of canvass and is where the Paint Event is and the class properties are defined. When a button is clicked, I set some of its properties, invalidate it, and then the paint event paints it accordingly.

This all works nicely under macOS and Windows. Under Linux, the buttons are there, but the paint event does not fire and so the buttons are not painted and so cannot be seen. If you can guess where they are, then clicking them works as it should but invisible buttons are not a feature I care to offer.

Are there some issues with this approach under Linux? Or is there something I should be doing and am not?

Added: feedback://showreport?report_id=58734

as workaround you can try .Refresh to draw instantly.

Tried .Refresh. Paint Event still doesn’t fire.

hmm, did you try it without emulator? maybe is the origin the VirtualBox.

Well, that’s possible I suppose. But the IDE runs OK, although perhaps it doesn’t use that feature. I don’t have a real Linux machine, so can’t test that directly.

you could test with boot linux on usb stick.