Continue Waiting?

Hi,

is there a switch to increase the wait time before the dialog comes?

I have a client with a slower computer and launching a bigger Web project always shows one or two dialogs where you have to click Continue before the web app is running.

There is no preference for that… but it should only appear during a debug run. Are you saying that this appears on a built app?

Fwiw, the other non-cancel option should make the dialog not appear a second time. I just don’t remember what the caption is.

no, while debugging.
But app starts regularly takes a long time on that older PC.
It would love to set the timeout for first dialog to a minute or so.

It’s designed to tell you that the startup of the app (before the app can serve sessions) is taking a long time.

But it shows right after launch.

So it compiles a minute or so, than you see it switches to launch.
And within a fraction of second, the dialog shows, so the app has no time to launch before this dialog is coming.

This has started happening again with large project in debug, 2019r2, Calamity oh I mean Catalina

Your application has failed to launch. If you continue to wait, it may launch. Otherwise, see the Messages pane for possible information that might explain the problem.

Choose Hide to stop being bugged by this, as it continues to popup otherwise during the debug session…which is now running in the browser. As Christian describes it displays this message almost instantly after compiling

Can we just get rid of this message please. I’m running on an 18 wheeler iMac Pro and it appears 3 times out of four debug runs, so I know it doesn’t only happen on slow computers. Admittedly my Web App is large, but it blocks me before I can even get the Login window to appear.

I can see no benefit with it. If my WebApp really is frozen I can close the browser and the IDE ends with a single click. If the IDE is really frozen, then I need to force-quit and set a breakpoint to find out where. I have never understood the need for this window.

Set it to a minute if I must have it, or set the Hide button to be the Escape key option rather than Cancel or use Command-Shift-H to Hide.

it is not about slow computers, it is about time to open the app and the first session.
I connect my web app to a remote database and it takes some 10s of seconds to do it, I get the message
if I don’t connect the database, I don’t get the message.

@Jean-Yves Pochez can you see any benefit of the message?

no, of course. first time I saw it I was very afraid.
it would be far better if the dialog would dismiss by itself after some time

Feature Request:
Remove the ‘Do you want to continue waiting for your application to launch?’ Warning when debugging a WebApp when it is slow to launch it’s first window.

Alternatively, provide an option to turn this warning off or allow the developer to increase the time delay before displaying the message.

feedback://showreport?report_id=61072

2 Likes