Compiling for 10.8

Hi all,

I just compiled an app and now I notice it doesn’t run on 10.8.
I get the message that the minimum macOS version required is 10.9

I run Xojo 2017r3 with MBS plugins 17.5

How come? Does anyone know?
Is it documented somewhere how far back Xojo apps will run with the various versions of Xojo?

Thanks for any input,
Marc

Hi Marc,

See here :
http://documentation.xojo.com/index.php/Deprecations

Franois

You may want to use an older Xojo version.
Xojo 2016r3 works on 10.7.

[quote=372721:@FranoisVanLerberghe]Hi Marc,

See here :
http://documentation.xojo.com/index.php/Deprecations

Franois[/quote]

Thanks for that link. On that page, there’s a link to a newer page: http://developer.xojo.com/deprecations
There I see that I need 2017r1.1

Luckily that’s not too far backwards.

Thanks!

The plugins have no similar requirement for 10.9, though?
I have customers and prospects using 10.7 and 10.8

Plugins are in general 10.4 and newer.
Maybe 10.6 for some parts.

I did debug my app on my 10.8 VM with Xojo 2017r11 and MBS 17.5 without problems.