Compile without error, but does not Run or Build

Hello All. I am trying to upgrade existing apps to Xojo 2014 r3. After walking through various changes needed, the project (apparently) compiles, but it does not continue to Run or complete a Build. It just finishes compiling and goes back waiting for input as if it has finished successfully.

I am running Win 8.1.

Anyone run across this? Or, any ideas?



I had seen this before with a previous version …

Happens some still with 2014 r3 but doesn’t seem to be nearly as often (maybe a few times per week). When I hit Run again (sometimes a 3rd time is needed), it will then work right … go figure???

Bottom line … No one responded back then that they had seen the problem and I haven’t seen anything about it from anyone else since until your input now. I just got used to it since it’s so infrequent.

Thanks for the reply, Don. I tried your suggestion clicking Run (8 times) one right after the other and still nothing. Glad it works for you though.


Where is your builds folder?
Are you using dropbox?

Jeff, I do not use dropbox for my projects. I use just sub folders under Documents. These same projects compile AND Run just fine on r2.1.

I just started a new desktop project and ran it. It compiled AND Ran correctly. Must be something in the current projects.


Erase temp files at %temp% folder
Clear Xojo caches

[quote=156653:@Rick Araujo]Erase temp files at %temp% folder
Clear Xojo caches

I had this exact thing happen under OSX last week and the OSX equivalent of the above suggestion worked…

Look in the taskmanager if your debugmyapp is still running somewhere. Sometimes in debugmode the running app isn’t closing allways.

I’ve had this on Windows within my vmware using shared folders with read-only rights. Xojo simply couldn’t create build folder. After applying read-write access everything worked. Also check your external files and/or xojo scripts.

I had this once and found both: a MBS message in a thread giving a UI alert (no alert given for debug) and some [quote]#if debugBuild then …[/quote] code that was needed to run properly.