Compile on Windows <> Compile on Mac for Windows?

I am currently at a customer where I try to get an app running on Windows 7 64 Bit.
After a lot of trying, I found a way to make it run but have no clue why:
If I compile the program on 2017r1.1Mac for Windows, no matter if 64 or 32 bit, it will not open the main window without further information why.
It runs on my own 32 bit virtual Win7 installation without problems.
Desperately I installed Xojo temporarily on the customer’s PC, compiled my application here: Et voilà! It’s working!
Is there any way to find out the reason?

Ownership attributes?
Avast Virus checker?

It runs on a first installment allowing to enter the data from my Mac built app, so this can’t be the reason.
It will not open the Main Window, neither on first run nor after.
There are Window splitters and a Searchfield on the main window, both by Einhugur, but why should they be the problem if they do run when I compile directly?

Could be stuck in a loop before displaying the window.
That doesnt explain the difference between the building on Mac or Windows however.
(Its to avoid this kind of thing that I build Mac on Mac, and Windows on Windows)

I thought so too, but the routine before runs completely fine. Somewhere during the open event something must get wrong. I tried to trace the reason but it simply crashes and Window’s error handling points me to files that don’t exist.

So you mean problems of that kind are not unknown? Even bigger to me is the mystery that it has no problems on my Parallels installation of Win 7, using the Mac built exe.


Currently the PC is occupied by the client. I’ll check it later.

NO! Not here. I use Xojo 2017 1.1 on my macOS (High Sierra currently) to build for Window 7 up to 10 (32 and 64 bits) and all issues alike were in the past caused by issues i created by myself. (There’s one exception, but that time i was “playing” with Beta Software…). :wink:

I also cant point to any actual known issues of that kind.
I do this to look smug in case one day there is such a problem.

[quote=337279:@Jeff Tullin]files that don’t exist.
This time i could retrieve the data. One of them below (I have no clue what it tries to tell me), the others are a .mdmp and and appccompat.txt file. I could upload them if they could be useful for debugging purposes.
(I did try 64 and 32 bit builds, both with the same result.)

<?xml version="1.0" encoding="UTF-16"?> <WERReportMetadata> <OSVersionInformation> <WindowsNTVersion>6.1</WindowsNTVersion> <Build>7601 Service Pack 1</Build> <Product>(0x30): Windows 7 Professional</Product> <Edition>Professional</Edition> <BuildString>7601.23807.amd64fre.win7sp1_ldr.170512-0600</BuildString> <Revision>1130</Revision> <Flavor>Multiprocessor Free</Flavor> <Architecture>X64</Architecture> <LCID>1031</LCID> </OSVersionInformation> <ProblemSignatures> <EventType>APPCRASH</EventType> <Parameter0>DaisyControl.exe</Parameter0> <Parameter1></Parameter1> <Parameter2>58f7477d</Parameter2> <Parameter3>XojoGUIFramework32.DLL</Parameter3> <Parameter4></Parameter4> <Parameter5>58f74b28</Parameter5> <Parameter6>c0000005</Parameter6> <Parameter7>0009733f</Parameter7> </ProblemSignatures> <DynamicSignatures> <Parameter1>6.1.7601.</Parameter1> <Parameter2>1031</Parameter2> <Parameter22>0a9e</Parameter22> <Parameter23>0a9e372d3b4ad19135b953a78882e789</Parameter23> <Parameter24>0a9e</Parameter24> <Parameter25>0a9e372d3b4ad19135b953a78882e789</Parameter25> </DynamicSignatures> <SystemInformation> <MID>7BAE9276-4E38-4C0A-B4DD-B6B3F27D4406</MID> <SystemManufacturer>ASUS</SystemManufacturer> <SystemProductName>All Series</SystemProductName> <BIOSVersion>2102</BIOSVersion> </SystemInformation> </WERReportMetadata>