Compile and Run for macOS fail with #104 error

I upgraded macOS to 10.13.4 and ever since when I run or compile my app for the second time I get a #104 error. For some reason Xojo isn’t able to delete the debug app or build folder. Any ideas? If I delete the debug app or build folder manually Xojo works.

I don’t see the option in Disk Utility to check permissions any more, but I did run First Aid on my drive. This didn’t help.

Running Xojo 2017r1.1, macOS 10.13.4, building macOS only.

Thanks in advance,


You can thank Apple for this. 104 is the File in Use error and is caused by the OS holding onto the previous build.

We added a workaround in 2017r3.

Thanks Greg. Will be updating to the latest Xojo shortly. Just handing on to be able to build for OS X 10.7+…

I’ve updated Xojo to 2018r1.1 but still having issues with this. I’m now getting #105 error if I build after running an app and the app project contains an app icon.

I’ve been able to reproduce this on macOS 10.13.4 by:

  • Create new desktop app in Xojo 2018r1.1
  • Add an app icon (I just dropped a 1024 png onto the 1024 preview box)
  • Build app (for macOS only)
  • Run app
  • Quit app
  • Build app again
  • Get #105 error

When I look inside the app bundle all it contains is the Contents > Resources > App.icons file.

I don’t get this issue building debug apps.

Any ideas? Anyone else getting this problem?

Yes. Reverting to a previous OS version fixed it for me.

Spotlight is holding open the icon file, there could be all manner of reasons for this, but the fact that it didn’t used too, implies where the bug is.

However I’ve also seen this a lot with other files on High Sierra, I modified my own delete routine to move the file to the trash if it can’t delete it. I think it has something to do with APFS.

Not at my computer, but could you log a feedback request asking Xojo to use the API to move the file to the trash if it fails to delete it.

The bug <> still is not fixed. And sometimes Xojo needs 5 minutes or so for quitting.

The IDE script to delete the debug app also is in the bug report.

I’m not seeing this problem with the debug app but the macOS built app. I’ve created a new (]Feedback Case #52864