Compilation of "untitled" failed

I just downloaded and installed 2023r1.1 in 10.13 High Sierra to test something, I went through the “this is from the internet, is it ok, blah blah” window (the installer was not copied from a network share). New Project, no changes, just clicked Run:

Compilation of “untitled” failed
An error occurred when attempting to launch the application.

Same thing happens when I click run again after pressing Cancel.

The project is unsaved and is brand new and unchanged.

Running in an Intel VM. Xojo 2021r2.1 runs fine on there (latest other install I have on that VM)

Changing to x86 64-bit from Universal makes no difference.

Saving the project and running it makes no difference (tried desktop and documents separately).

Show all filename extensions is unchecked in finder.

If I run Xojo from the command line, nothing is shown as I click run following the same steps with a new project.

Any ideas on how to diagnose and fix this?


Xojo’s system requirements says:

macOS 10.14 (Mojave) - 13 (Ventura)

By default, Mojave will be the minimum OS for a project built/run with 2023r1.1. While I haven’t tried it, I’m surprised you have the IDE itself running on HS.

For your project, you can lower the minimum OS in the Inspector (don’t have it in front of me right now.). I still have some of mine working down to Yosemite.

Wonderful, download, install, run and not a single message letting me know its not on the correct version of the OS. Teach me for taking Windows backwards compatibility for granted.

The documentation for requirements is also a mess with 2022r4 requirements pointing to 2022r3 and 2022r4.1 pointing to 2022r4, I assume its because they have the same requirements, but without knowing it could be just a documentation error.

Moving over to Mojave or back to an older version solved the issue, thanks.

1 Like

When an app can’t run on an older version of macOS then it can’t even be started. Building works fine. Just the debugger doesn’t start.

Not possible to debug on High Sierra anymore

And the issue was closed:

Running 2023r1.1 on Ventura here. I am able to remote-debug to a Fusion High Sierra guest if I have an AppWrapper build script in the build settings, the script is set to run in debug mode, and both the project and its AppWrapper file have the appropriate setting for minimum OS.

My main computer still is on High Sierra. I love this version of macOS because it’s the last sane version. I need to update to Mojave anyways - soon. I can’t use 2023r1 because of the problem with the stack on Intel.

1 Like

Sane “eventually”. If I remember, HS was the one that initially had the bug where you could log in as root with a blank password (after it then asked you to set the password.) :slight_smile: