Compilation of "myapp" failed

Since yesterday, I am dealing with a nasty problem under macOS Sierra Beta. It never happened to me before, so I am at a loss. In all Xojo versions pass 2014 when I click run, compile seems to go fine, then I get a MsgBox saying :

Compilation of “myapp” failed
An error occurred when attempting to launch the application

If I try to build the result is a non working app. Although I can launch the Unix executable inside the bundle.

I filed a bug report but Xojo cannot reproduce the issue.

What can I try to fix things up ?

Have you done the usual suspects? Can you compile “Hello World”? Have you reinstalled Xojo? Did you try to remove the plugins? Do you have plugins that need to be installed like Valentina?

Hello world compiles and runs fine. What I don’t understand is why all the sudden a project that ran just fine would stop.

I removed the plugins, no luck.

I don’t use Valentina.

Do you have any build scripts?

No build script, no special declares. I just fetched the project from the previous version of the program, same issue.

Where are the caches I can delete ?

Well, deleted the cache to no avail. Going to restore with Time Machine…

Have you tried in a fresh VM?

A reboot often cures sudden ailments :slight_smile:

Tried reboot of course.

When I try to launch the project under El Capitan everything is OK.

I strongly suspect there is something fishy happening to Xojo under macOS Sierra.

I am in the process now to reinstate El Capitan, and forget Sierra for the time being. I may come back to Sierra when I have time to waste…

Thank you all.

Try to remove any previous builds that would have been overwritten. That has helped for me :slight_smile:

I thought about that immediately. In the case of a run, the previous build is correctly deleted. Building works fine as well. The resulting app bundle is simply bad. Although the Unix executable is valid. Which convinces me something is wrong between Xojo and Sierra.

Anyway, in a few minutes I shall start over with El Capitan hopefully with no more issue.

Alright. I reinstated El Capitan and everything is OK again. Definitely a problem with Sierra.

Is this related to the private case you filed ?
If so its worth adding this finding to the end of that case

[quote=273320:@Norman Palardy]Is this related to the private case you filed ?
If so its worth adding this finding to the end of that case[/quote]

Yes, it is. I will add that.

FWW: I have no issues compiling all my projects running macOS 10.12 beta and Xojo 2016 1.1 - most uses declares, MBS plugins and dtPlugins.
All compiled apps work fine here.

The only problem still remains the quarantine issues - but my dirty trick code posted earlier fixes this. :slight_smile:

The issue I encountered did not manifest right away. It started with a FileType that when empty compiled fine, but as soon as I added a type, I got the compilation failed message. When I took the type off, it compiled again. I reported right away.

Then all the sudden, Check Printer that used to work perfectly stopped compiling as soon as I added a new version of RubberViews. But removing it again did not fix the problem.

The only thing that worked was to compile with a 2014 version or less.There seems to be a definite issue between Sierra and more recent versions.

I cannot afford to live dangerously anymore. Back to EC, until I am reasonably certain Sierra does not bite.

I just ran into this same issue. Was anything cleared up on it?

On Sierra 10.12.4

I’m using 2016r4.1, working on an app using ARGen, complemented by Navicat for SQLite.

quit everything,
shut down,
run only Xojo,
build (or run)…

Quick tip and solution could be, just to rename a main Xojo project file e.g. myprojectname.xojo_binary_project -> myprojectname1.xojo_binary_project :slight_smile:
or to do SAVE AS from File menu in Xojo.

Rebooting/shutting down also sometimes will not help but above thing is working for sure if you want to move ahead with work and stop chasing for hacking solution.

I’m using Xojo 2017.R2