Compilation failure (error 104)

I am running Xojo 2017 release 2.1 on an iMac running High Sierra. When I run an app in the debuguer, it runs fine.

But when I run it again, it get compilation failed with an error 104 (application running, destination director locked).

Looking at the build directory, I find it is empty.

Restarting my computer solved the problem but that seems a bit extreme.

Anyone know what is going on?

see here for example, for a possible solution

I just get the same error, but conditions differs (I think):

2015r1 running in the IDE…
2017r2.1 opened to check if the found bug with the previous Xojo version.
Then I run it to make the test.

The error 104 appears.

I quit the running application in 2015r1, run it in 2017r2.1 and this works fine.

El Capitan.

The problem relates to the (app name)
It needs to be deleted before the next run. Apparently fixed in release 3, but on 2.1 I still have the same problem on High Sierra.
There are scripts around that enable automatic deleting of this.