Compilation Fails with Error 103

I’ve been working with a Xojo project for 2 years and have continuously upgraded through each Xojo version as it was released. Today I upgrade to Xojo 2015r3 and much to my surprise, I can no longer build the OS X target of my project.

I am developing and building this project on OS X 10.10.5 for the OS X target. The project was last built successfully on Xojo 2015r2.4. Now, with Xojo 2015r3 I get this error dialog:

[quote]Compilation of “” failed.

A file system error occurred (#103) for ““Resources””. If the application already exists, please make sure that it is not currently running; otherwise, please make sure that the destination directory is writable.

Of course, my actual project name does appear in the dialog window. This error occurs immediately after the Linking step. The application bundle is created and contains the binary, plist, Xojo framework, PkgInfo, and the data copied into Resources by my build script – but the Resources directory is missing the application’s graphics.

I have tried switching the new option to build a 64-bit target, but I still get the same result.

And oddly, I can run the app and debug it from within the IDE.

And, the Windows build still works fine.

Does anyone have any idea why this would be broken after an upgrade to 2015r3?

Would you be targeting the Resources folder in a Windows project ? Now the folder name contains the project name as in

myApp Resources

I have build steps that copy a few additional items into the Resources folder on both my OS X and Windows targets. However, my Windows build is still working. It’s the OS X build that fails with the above error message.

Just to make sure that I didn’t break anything on my build destination volume, I opened the same project with 2015r2.4 and hit build and the OS X version is built properly. Success.

I close that up and open the project in 2015r3 and hit build and the build fails.

I am building to a mounted server volume. The server is running OS X Server 10.10.5, and it works with Xojo 2015r2.4. I can’t imagine that the server is the problem, especially since I’ve reverted to r2.4 and it builds fine.

Unless anyone in the forum has a workaround suggestion, I’ll file a bug. In the state that it’s in, 2015r3 is not usable in my environment.

I have the same problem with r3.0 and r3.1, is not usable in my environment.
I am building to a mounted server volume. The server is running OS X Server 10.9.X, and it works with Xojo 2015r2.4
Does anyone have a solution?

Is there already a build the f your project in the builds folder? Does removing it first help?

There is a bug report in Feedback that has more information. Please consider adding information to this bug report in addition to the forum so that the IDE developers can get this solved quickly: