Compilation failed...!!

Since a little while I cannot build any APPs (after a first run). I do not know whether it comes from MAC OS Sierra 10.12.26 or from the last version of Xojo 2017.2.1

Indeed, after the first run of building an Apps (even if I try to run several samples…) then I got the Error message :

Thus, it is impossible to launch a second build or to run the Apps after the first attempt (most of the time is occurs for WebApps).
The only workaround solution is to reboot my MAC… Which is becoming quite ridiculous …

If there any fixes or way to avoid that issue.

I read somewhere in that forum that, by settings up a new temporary folder in the setting “Build unsaved Apps In”… could solve the issue…
But unfortunately, after having set a new build folder and reboot my MAC… the issue is still there …

Could anyone, help me out… Because I can’t move forward to complete the Apps, since rebooting the MAC is not at all an option…

Regards and tank you for your help

It’s a known problem.
Problem with High Sierra and debug

You have to remove <your_appname>.debug in your project folder before compiling or after quitting the debug session.

Hi Paul

Sorry, but your answer is not complete and may be wrong… Let me tell you why :

  1. If I save the Project, under a specific folder, and I run it:
    a) The first time it works fine
    b) the second and other time, then I’l still having the same issue (the same error message)
    The only way to make it run (compiled) it’s to delete a file called “My Application.debug” located in the project folder.
    Basically in that project folder, Xojo creates at the run time a folder with the same name “My Application.debug”
    where you can find that file too “My Application.debug”
    Finally the workaround solution is to delete that file or folder created by Xojo called “My Application.debug”

  2. If I do not save the project ( such as the sample provided by Xojo) and I just run it (it only happens with the Web Apps)
    then, I got that error message… And I can"t compile/run any sample as long as that file called “My Application.debug” is present.
    The point is I do not know where Xojo creates/stores that file “My Application.debug”, since it is created by Xojo IDE,
    in the temporary folder which is mentioned in the settings :

    In a nutshell, as I succeeded to make it work when the project is saved (see the point 1 above) I’ve got to delete this file too
    that is stored in the Xojo temporary folder…
    In Conclusion, does anyone know where is the Xojo temporary folder in MAC OS ?? In order to delete that file before running the Apps and then being able to perform my test…


This topic has been discussed several times. The temporary solution is an IDE script to delete the debug app.

To find the temporary folder make a new Xojo project, add a button and in the Action event the following code:

dim f as FolderItem = SpecialFolder.Temporary f = f.Parent f.Launch

Or use the application “Find any File” to find new files when you run an unsaved Xojo project.

  1. Of course it runs fine the first time.
    There is no .debug file.
    Every time after that, the .debug file exists and has to be removed manually or by script before you can compile without the error message.

  2. You can change “Build unsaved apps in:” setting to any desired location.
    This way it will be easy for you to find the .debug file.
    When the “Build unsaved apps in:” setting is empty, the .debug file will be created in your project folder.

In the thread I mentioned before, there are examples of scripts to get rid of the .debug file.

I must be doing something wrong (I just ran afoul of this issue)… I tried various scripts, and none did anything.
I did see where some mentioned “be sure script runs before the build”. but I see no option to control when it is run, just if it is for “debug” , “release” or both

You define the Order of Build Scripts by the order of the Scripts in the Navigator. They will be executed from top to bottom. :slight_smile:

ok… so when I added it, it was ‘last’, so I need to drag it to above “App” then?

is there a way to define the script so all projects use it by default? or does it have to be added to each project

Yes&No: :slight_smile: You need to drag it above “Build”, because we are talking about Build Scripts, they should be in the Build Section of the selected OS at the bottom of the List in the Navigator. Right? (Not at my Workdesk, can’t show screens)

None i know of.

Add it to the template project ?