Comodo firewall blocks xojo debug web app in the IDE

Just discovered that in order to debug a webapp in Xojo, I need to shutdown the Comodo Firewall.
When starting the debug session, a firewall message pops up saying that the app is accessing the internet and I must give permission. I say ok, grant permission, and then nothing happens. Host is localhost.

Comodo Firewall down= webapp debugger runs fine.

The firewall is in safe setting, where it asks everytime a new application needs to access the network, with minimal number of alerts. But every other application goes thru once it has permission.

This is because every time you debug an app it is a new application. You may want to consider white listing localhost or the directory.

Thanks Bob, but the problem is not that the firewall asks, that, I understand perfectly, new build,different app. The problem is that once I grant permission, Xojo fails to launch a browser window with my web app.

Sounds like what Sophos used to do to me until I white listed my development folders.