Cocoa TextField automatically replace TM with ™

Hello !

Anybody else has the string “TM” automatically replaced with “™” in a Cocoa TextField ??
AutomaticallyCheckSpelling is not enabled… how can i avoid it ?

Thanks

Forgot to add… to trigger the change simply add a space after the TM … so "TM "

Solved… it’s a problem related to OS X.
It’s a setting in System Preferences -> Language & Text -> Text

Indeed - Now that it’s a NSTextField, you get all the benefits of it being so, including using Text Substitution. Which can be disabled in System Preferences if that’s not what you want.