CentOS7 x64 install


I’ve followed all the directions regarding 32bit libraries from the downloads page, but am still having an issue with a dependency conflict.
First I tried running the RPM file from the file browser. It gave me a message box saying “Two packages provide the same file. This is usually due to mixing packages from different software sources.”
Then I used the shell to try and get some more information
$sudo rpm -i -v xojo2015r24.rpm

It gave me several failed dependencies. Most of them were for GTK and one for ncurses.
I installed GTK2 via yum and all but one failed dependency has disappeared. By looking up the remaining lib via yum provides, I traced it to ncurses-libs.i686, so I installed it.
However then I got a conflict message:

[spiridonov@localhost Downloads]$ sudo rpm -i -v xojo2015r24.rpm
Preparing packages…
file / from install of xojo2015r2.4-2015.02.4-2.i386 conflicts with file from package filesystem-3.2-18.el7.x86_64

I uninstalled the ncurses-libs.i686 package and went back to seeing the failed dependency error:

[spiridonov@localhost Downloads]$ sudo rpm -i -v xojo2015r24.rpm
error: Failed dependencies:
libncurses.so.5 is needed by xojo2015r2.4-2015.02.4-2.i386

I did a yum search for “filesystem” however there is no i686 version of it (which I was hoping would resolve the dependency).

Can anyone recommend a workaround?

I vaguely recall coming across this a while back, I simply installed from the .tar archive instead.
I have Xojo running successfully on CentOS 7.

RPM file is broken years ago for recent distros.

As Martin said you must use the tar.gz. This is Feedback #33064 from Apr-2014 and verified since then, but not solved.

I once had the same problem with Xojo in Arch Linux. Xojo requires libncurses.so.5 while current version is libncurses.so.6. So, you need to provide libncurses.so.5, or create a link from libncurses.so.6.